summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-14 18:56:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-14 18:56:00 +0000
commit021f975b7a5ff8330f883b88a00c04a55ad1751e (patch)
tree164bd96735f5da058de77ebcb105acc09ee3f88a /app-admin
parentStable on amd64 wrt bug #311355 (diff)
downloadgentoo-2-021f975b7a5ff8330f883b88a00c04a55ad1751e.tar.gz
gentoo-2-021f975b7a5ff8330f883b88a00c04a55ad1751e.tar.bz2
gentoo-2-021f975b7a5ff8330f883b88a00c04a55ad1751e.zip
Set SUPPORT_PYTHON_ABIS (bug #308287).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog6
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild50
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild45
3 files changed, 54 insertions, 47 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 57999ed039b2..edf92db19b7b 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.64 2010/03/10 03:16:31 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.65 2010/05/14 18:56:00 arfrever Exp $
+
+ 14 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ webapp-config-1.50.16-r1.ebuild, webapp-config-1.50.16-r3.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #308287).
10 Mar 2010; Sebastian Pipping <sping@gentoo.org>
webapp-config-1.50.16-r1.ebuild, webapp-config-1.50.16-r3.ebuild:
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
index e976995932e6..d303040bc873 100644
--- a/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
@@ -1,8 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild,v 1.13 2010/03/10 03:16:31 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild,v 1.14 2010/05/14 18:56:00 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
@@ -14,15 +18,16 @@ KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-f
IUSE=""
DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="WebappConfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-apache-move.patch
+src_prepare() {
+ epatch "${FILESDIR}/${P}-apache-move.patch"
}
src_install() {
-
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
# distutils does not provide for specifying two different script install
@@ -30,33 +35,30 @@ src_install() {
# be ok
distutils_src_install --install-scripts="/usr/sbin"
- dodir /etc/vhosts
- cp config/webapp-config "${D}"/etc/vhosts/
+ python_convert_shebangs 2 "${ED}usr/sbin/webapp-config"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
keepdir /usr/share/webapps
keepdir /var/db/webapps
+
dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt CHANGES.txt examples/postinstall-en.txt
- doman doc/webapp-config.5 doc/webapp-config.8
- dohtml doc/webapp-config.5.html doc/webapp-config.8.html
+ doman doc/*.[58]
+ dohtml doc/*.[58].html
}
src_test() {
- distutils_python_version
- if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
- elog "Running webapp-config doctests..."
- if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
- eerror "DocTests failed - please submit a bug report"
- die "DocTesting failed!"
- fi
- else
- elog "Python version below 2.4! Disabling tests."
- fi
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" WebappConfig/tests/dtest.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
- echo
+ distutils_pkg_postinst
+
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"
elog "packages that use webapp-config."
- echo
- epause 5
}
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
index 417ed7c2cefa..38b17acbbafd 100644
--- a/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
@@ -1,8 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild,v 1.3 2010/03/10 03:16:31 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild,v 1.4 2010/05/14 18:56:00 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
@@ -14,14 +18,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE=""
DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="WebappConfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-apache-move.patch
- epatch "${FILESDIR}"/${P}-baselayout2.patch
- epatch "${FILESDIR}"/${P}-htdocs-symlink.patch
- epatch "${FILESDIR}"/${P}-absolute-paths.patch
+src_prepare() {
+ epatch "${FILESDIR}/${P}-apache-move.patch"
+ epatch "${FILESDIR}/${P}-baselayout2.patch"
+ epatch "${FILESDIR}/${P}-htdocs-symlink.patch"
+ epatch "${FILESDIR}/${P}-absolute-paths.patch"
rm -f doc/webapp.eclass.5{,.html}
}
@@ -33,6 +39,8 @@ src_install() {
# be ok
distutils_src_install --install-scripts="/usr/sbin"
+ python_convert_shebangs 2 "${ED}usr/sbin/webapp-config"
+
insinto /etc/vhosts
doins config/webapp-config
@@ -45,23 +53,16 @@ src_install() {
}
src_test() {
- distutils_python_version
- if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
- elog "Running webapp-config doctests..."
- if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
- eerror "DocTests failed - please submit a bug report"
- die "DocTesting failed!"
- fi
- else
- elog "Python version below 2.4! Disabling tests."
- fi
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" WebappConfig/tests/dtest.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
- echo
+ distutils_pkg_postinst
+
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"
elog "packages that use webapp-config."
- echo
- epause 5
}