summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-23 22:27:19 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-23 22:27:19 +0000
commitec164efe21310a7435eb0812451e2a29d4960507 (patch)
treecf2470c378d47db57cfc7210b99fefa3baed5d44 /app-admin/system-tools-backends
parentVersion bump. (diff)
downloadgentoo-2-ec164efe21310a7435eb0812451e2a29d4960507.tar.gz
gentoo-2-ec164efe21310a7435eb0812451e2a29d4960507.tar.bz2
gentoo-2-ec164efe21310a7435eb0812451e2a29d4960507.zip
Bump eapi and follow current policies
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-admin/system-tools-backends')
-rw-r--r--app-admin/system-tools-backends/ChangeLog7
-rw-r--r--app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild43
2 files changed, 29 insertions, 21 deletions
diff --git a/app-admin/system-tools-backends/ChangeLog b/app-admin/system-tools-backends/ChangeLog
index 54652bab07b7..25897f6546d5 100644
--- a/app-admin/system-tools-backends/ChangeLog
+++ b/app-admin/system-tools-backends/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/system-tools-backends
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-tools-backends/ChangeLog,v 1.78 2014/06/22 18:46:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-tools-backends/ChangeLog,v 1.79 2014/11/23 22:27:19 pacho Exp $
+
+ 23 Nov 2014; Pacho Ramos <pacho@gentoo.org>
+ system-tools-backends-2.10.2.ebuild:
+ Bump eapi and follow current policies
22 Jun 2014; Markus Meier <maekke@gentoo.org>
system-tools-backends-2.10.2.ebuild:
@@ -393,4 +397,3 @@
09 Mar 2005; Joe McCann <joem@gentoo.org> +metadata.xml,
+system-tools-backends-1.2.0.ebuild:
New package. Backend for gnome-system-tools
-
diff --git a/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild b/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild
index 9d826e81f515..c67c0ab21630 100644
--- a/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild
+++ b/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild,v 1.10 2014/06/22 18:46:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-tools-backends/system-tools-backends-2.10.2.ebuild,v 1.11 2014/11/23 22:27:19 pacho Exp $
-EAPI="3"
+EAPI="5"
GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
-inherit eutils gnome2 user
+inherit eutils gnome2 readme.gentoo user
DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
HOMEPAGE="http://projects.gnome.org/gst/"
@@ -15,48 +16,52 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc sparc x86"
IUSE=""
-RDEPEND="!<app-admin/gnome-system-tools-1.1.91
+RDEPEND="
+ !<app-admin/gnome-system-tools-1.1.91
>=sys-apps/dbus-1.1.2
>=dev-libs/dbus-glib-0.74
>=dev-libs/glib-2.15.2:2
>=dev-perl/Net-DBus-0.33.4
dev-lang/perl
>=sys-auth/polkit-0.94
- userland_GNU? ( virtual/shadow )"
-
+ userland_GNU? ( virtual/shadow )
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
>=dev-util/intltool-0.40"
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- G2CONF="${G2CONF}
- --localstatedir=/var"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need to add yourself to the group stb-admin and
+add system-tools-backends to the default runlevel.
+You can do this as root like so:
+# rc-update add system-tools-backends default
+"
+pkg_setup() {
enewgroup stb-admin
}
src_prepare() {
- gnome2_src_prepare
-
# Change default permission, only people in stb-admin is allowed
# to speak to the dispatcher.
epatch "${FILESDIR}/${PN}-2.8.2-default-permissions.patch"
# Apply fix from ubuntu for CVE 2008 4311
epatch "${FILESDIR}/${PN}-2.8.2-cve-2008-4311.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --localstatedir=/var
}
src_install() {
gnome2_src_install
- newinitd "${FILESDIR}"/stb.rc system-tools-backends
+ readme.gentoo_create_doc
}
pkg_postinst() {
- echo
- elog "You need to add yourself to the group stb-admin and"
- elog "add system-tools-backends to the default runlevel."
- elog "You can do this as root like so:"
- elog " # rc-update add system-tools-backends default"
- echo
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
}