summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 21:25:15 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 21:25:15 +0000
commit8e8e0eb40eeb53da3b9f68240695efab21919782 (patch)
tree6547d196a4f2fe8eabe03253f05ed17858986b84 /app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
parentA multi-sourced configuration back-end (diff)
downloadgentoo-2-8e8e0eb40eeb53da3b9f68240695efab21919782.tar.gz
gentoo-2-8e8e0eb40eeb53da3b9f68240695efab21919782.tar.bz2
gentoo-2-8e8e0eb40eeb53da3b9f68240695efab21919782.zip
Apache configuration tool
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild')
-rw-r--r--app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
new file mode 100644
index 000000000000..7ca9bfc2bdaa
--- /dev/null
+++ b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild,v 1.1 2006/09/05 21:25:15 dberkholz Exp $
+
+inherit eutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1.1.1"
+
+DESCRIPTION="Apache configuration tool"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-libs/alchemist
+ =dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ >=net-www/apache-2.0.52-r3
+ sys-apps/usermode
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxslt python; then
+ local msg="Build dev-libs/libxslt with USE=python"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}