summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:37:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:37:16 +0000
commitfd4f7c1fd26b9b3b0d1d540aa1f2ea9fa19309fa (patch)
tree7ce95eeb8c00a2c796ff8d8276d5d6161126a965 /app-admin/sabayon/sabayon-2.30.1.ebuild
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-fd4f7c1fd26b9b3b0d1d540aa1f2ea9fa19309fa.tar.gz
gentoo-2-fd4f7c1fd26b9b3b0d1d540aa1f2ea9fa19309fa.tar.bz2
gentoo-2-fd4f7c1fd26b9b3b0d1d540aa1f2ea9fa19309fa.zip
Version bump. Translation updates. Drop *.la file installation, bug #299638.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/sabayon/sabayon-2.30.1.ebuild')
-rw-r--r--app-admin/sabayon/sabayon-2.30.1.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/sabayon/sabayon-2.30.1.ebuild b/app-admin/sabayon/sabayon-2.30.1.ebuild
new file mode 100644
index 000000000000..955365f572bd
--- /dev/null
+++ b/app-admin/sabayon/sabayon-2.30.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/sabayon-2.30.1.ebuild,v 1.1 2010/09/28 21:37:16 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils python multilib
+
+DESCRIPTION="Tool to maintain user profiles in a GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/sabayon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Unfortunately the configure.ac is wildly insufficient, so dependencies have
+# to be got from the RPM .spec file...
+# But the .spec file got removed :/
+COMMON_DEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.6.0
+ >=dev-python/pygtk-2.16
+ >=dev-python/pygobject-2.15
+ app-admin/pessulus
+ x11-libs/pango
+ dev-python/python-ldap
+ x11-base/xorg-server[kdrive]"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg
+ dev-libs/libxml2[python]
+ >=gnome-base/gconf-2.8.1
+ >=dev-python/libbonobo-python-2.6
+ >=dev-python/gconf-python-2.6
+ x11-libs/gksu"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.17.3"
+
+DOCS="AUTHORS ChangeLog ISSUES NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-distro=gentoo
+ --with-prototype-user=${PN}-admin
+ --enable-console-helper=no"
+
+ einfo "Adding user '${PN}-admin' as the prototype user"
+ # I think /var/lib/sabayon is the correct directory to use here.
+ enewgroup ${PN}-admin
+ enewuser ${PN}-admin -1 -1 "/var/lib/sabayon" "${PN}-admin"
+ # Should we delete the user/group on unmerge?
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Switch gnomesu to gksu; bug #197865
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop || die "gksu sed failed"
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop.in || die "gksu sed failed"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/sabayon
+
+ # unfortunately /etc/gconf is CONFIG_PROTECT_MASK'd
+ elog "To apply Sabayon defaults and mandatory settings to all users, put"
+ elog ' include "$(HOME)/.gconf.path.mandatory"'
+ elog "in /etc/gconf/2/local-mandatory.path and put"
+ elog ' include "$(HOME)/.gconf.path.defaults"'
+ elog "in /etc/gconf/2/local-defaults.path."
+ elog "You can safely create these files if they do not already exist."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/sabayon
+}