summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-07-07 18:39:19 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-07-07 18:39:19 +0000
commitbe976d66cac1f7d399b9597cc8122dca00bf23d6 (patch)
tree004dce36c407af6490faa2ec2ed196ed41c2be60 /app-admin/fleet
parentFix building with glib-2.44 (#554126 by Franz Fellner) (diff)
downloadgentoo-2-be976d66cac1f7d399b9597cc8122dca00bf23d6.tar.gz
gentoo-2-be976d66cac1f7d399b9597cc8122dca00bf23d6.tar.bz2
gentoo-2-be976d66cac1f7d399b9597cc8122dca00bf23d6.zip
rev bump to encorporate the changes from the live ebuild, approved by alunduil
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'app-admin/fleet')
-rw-r--r--app-admin/fleet/ChangeLog7
-rw-r--r--app-admin/fleet/fleet-0.11.0-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-admin/fleet/ChangeLog b/app-admin/fleet/ChangeLog
index 81980ca80e5f..9c36f68f9648 100644
--- a/app-admin/fleet/ChangeLog
+++ b/app-admin/fleet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/fleet
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/fleet/ChangeLog,v 1.24 2015/07/07 18:14:09 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fleet/ChangeLog,v 1.25 2015/07/07 18:39:19 williamh Exp $
+
+*fleet-0.11.0-r1 (07 Jul 2015)
+
+ 07 Jul 2015; William Hubbs <williamh@gentoo.org> +fleet-0.11.0-r1.ebuild:
+ rev bump to encorporate the changes from the live ebuild, approved by alunduil
07 Jul 2015; William Hubbs <williamh@gentoo.org> fleet-9999.ebuild:
with approval of alunduil: add slot dependency on dev-lang/Go and drop keepdir
diff --git a/app-admin/fleet/fleet-0.11.0-r1.ebuild b/app-admin/fleet/fleet-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..0480e02e9f9c
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fleet/fleet-0.11.0-r1.ebuild,v 1.1 2015/07/07 18:39:19 williamh Exp $
+
+EAPI=5
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.3:=
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}
+
+pkg_postinst() {
+ ewarn "Please read this if you are upgrading from a version <0.10.0-r1."
+ ewarn ""
+ ewarn "Starting with fleet 0.10 the fleetctl utility has"
+ ewarn "'--endpoint=unix:///var/run/fleet.sock' as default argument, which is"
+ ewarn "why we have introduced the fleet.socket unit and renamed the service"
+ ewarn "from fleetd.service to fleet.service. If you run fleet on system"
+ ewarn "startup, please re-enable it via 'systemctl enable fleet'."
+}