summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-28 20:39:55 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-28 20:39:55 +0000
commitf4f2229cf1f1401b229ba525ab9fda559f84a962 (patch)
treebeabd3f6f0cd0421e0e215dd5884a8252c937d2c /app-admin/eselect-unison
parentSmall fix (diff)
downloadgentoo-2-f4f2229cf1f1401b229ba525ab9fda559f84a962.tar.gz
gentoo-2-f4f2229cf1f1401b229ba525ab9fda559f84a962.tar.bz2
gentoo-2-f4f2229cf1f1401b229ba525ab9fda559f84a962.zip
Version bump to add prefix support
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-admin/eselect-unison')
-rw-r--r--app-admin/eselect-unison/ChangeLog10
-rw-r--r--app-admin/eselect-unison/eselect-unison-0.3.ebuild26
-rw-r--r--app-admin/eselect-unison/files/unison.eselect-0.3146
3 files changed, 180 insertions, 2 deletions
diff --git a/app-admin/eselect-unison/ChangeLog b/app-admin/eselect-unison/ChangeLog
index 31edb4dd821c..6997b0b50c92 100644
--- a/app-admin/eselect-unison/ChangeLog
+++ b/app-admin/eselect-unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-unison
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/ChangeLog,v 1.9 2009/11/22 17:39:04 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/ChangeLog,v 1.10 2010/02/28 20:39:53 abcd Exp $
+
+*eselect-unison-0.3 (28 Feb 2010)
+
+ 28 Feb 2010; Jonathan Callen <abcd@gentoo.org> +files/unison.eselect-0.3,
+ +eselect-unison-0.3.ebuild:
+ Version bump to add prefix support
*eselect-unison-0.2 (22 Nov 2009)
diff --git a/app-admin/eselect-unison/eselect-unison-0.3.ebuild b/app-admin/eselect-unison/eselect-unison-0.3.ebuild
new file mode 100644
index 000000000000..4505c35e47f6
--- /dev/null
+++ b/app-admin/eselect-unison/eselect-unison-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/eselect-unison-0.3.ebuild,v 1.1 2010/02/28 20:39:53 abcd Exp $
+
+inherit eutils
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-admin/eselect-unison/files/unison.eselect-0.3 b/app-admin/eselect-unison/files/unison.eselect-0.3
new file mode 100644
index 000000000000..db1782f222cd
--- /dev/null
+++ b/app-admin/eselect-unison/files/unison.eselect-0.3
@@ -0,0 +1,146 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/files/unison.eselect-0.3,v 1.1 2010/02/28 20:39:55 abcd Exp $
+
+DESCRIPTION="Manage /usr/bin/unison versions"
+MAINTAINER="ml@gentoo.org"
+VERSION="0.3"
+
+# find a list of unison symlink targets, best first
+find_targets() {
+ local f
+ for f in "${EROOT}"/usr/bin/unison-[0-9]*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/unison-}"
+ fi
+ done | tac
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${EROOT}"/usr/bin/unison)"
+ echo "${f##*/unison-}"
+}
+
+# try to remove the unison symlink
+remove_symlinks() {
+ rm -f "${EROOT}"/usr/bin/unison &>/dev/null
+}
+
+# set the unison symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets) )
+ target=${targets[target - 1]}
+ fi
+ if [[ -f "${EROOT}/usr/bin/unison-${target}" ]] ; then
+ remove_symlinks
+ ln -s "unison-${target}" "${EROOT}/usr/bin/unison" || \
+ die "Could not set ${target} /usr/bin/unison symlink"
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current unison version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current unison verson:"
+ if [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available unison versions"
+}
+
+do_list() {
+ [[ $# -eq 0 ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available unison versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new unison version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ die -q "${EROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the unison version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${EROOT}/usr/bin/unison" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${EROOT}/usr/bin/unison" ]] ; then
+ die -q "${EROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}