summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2013-01-26 04:08:04 +0000
committerMatt Turner <mattst88@gentoo.org>2013-01-26 04:08:04 +0000
commitdbb4108feefd5e1dfe348b4e8eb42ad31f445238 (patch)
tree539ff05e02f4e82fc644fdd9c456bb36685bbb18 /app-admin/eselect-opengl
parentactually compile (bug #454076) (diff)
downloadgentoo-2-dbb4108feefd5e1dfe348b4e8eb42ad31f445238.tar.gz
gentoo-2-dbb4108feefd5e1dfe348b4e8eb42ad31f445238.tar.bz2
gentoo-2-dbb4108feefd5e1dfe348b4e8eb42ad31f445238.zip
Version bump to support GLES3 headers, bug 444114. Also update glext.h and glxext.h, bug 452022.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'app-admin/eselect-opengl')
-rw-r--r--app-admin/eselect-opengl/ChangeLog10
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.2.7.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index eccfe0600b53..de709b10f49d 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-opengl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.111 2012/12/02 20:42:25 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.112 2013/01/26 04:08:04 mattst88 Exp $
+
+*eselect-opengl-1.2.7 (26 Jan 2013)
+
+ 26 Jan 2013; Matt Turner <mattst88@gentoo.org> +eselect-opengl-1.2.7.ebuild:
+ Version bump to support GLES3 headers, bug 444114. Also update glext.h and
+ glxext.h, bug 452022.
02 Dec 2012; Agostino Sarubbo <ago@gentoo.org> eselect-opengl-1.2.6.1.ebuild:
Stable for ppc64, wrt bug #432400
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.2.7.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.2.7.ebuild
new file mode 100644
index 000000000000..6724703c3174
--- /dev/null
+++ b/app-admin/eselect-opengl/eselect-opengl-1.2.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.2.7.ebuild,v 1.1 2013/01/26 04:08:04 mattst88 Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenGL interface being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.opengl.org/registry/api/glext.h
+# http://www.opengl.org/registry/api/glxext.h
+GLEXT="85"
+GLXEXT="34"
+
+MIRROR="http://dev.gentoo.org/~mattst88/distfiles"
+SRC_URI="${MIRROR}/glext.h.${GLEXT}.xz
+ ${MIRROR}/glxext.h.${GLXEXT}.xz
+ ${MIRROR}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-admin/eselect-1.2.4
+ !<media-libs/mesa-8.0.3-r1
+ !<x11-proto/glproto-1.4.15-r1"
+
+pkg_postinst() {
+ local impl="$(eselect opengl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opengl set "${impl}"
+ fi
+}
+
+src_prepare() {
+ # don't die on Darwin users
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/libGL\.so/libGL.dylib/' opengl.eselect || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/eselect/modules"
+ doins opengl.eselect
+ doman opengl.eselect.5
+
+ # Install global glext.h and glxext.h
+ insinto "/usr/$(get_libdir)/opengl/global/include/GL/"
+ cd "${WORKDIR}"
+ newins glext.h.${GLEXT} glext.h
+ newins glxext.h.${GLXEXT} glxext.h
+}