summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-03 15:11:14 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-03 15:11:14 +0000
commit81f18e960d17b4b2ce08eef3b1a96bdb33379df7 (patch)
tree48ce4779c5b6b7c2c84f467597ec540150934b8e /app-admin/ansible
parentrevbump -> EAPI 5, add IUSE examples, fix src_install (diff)
downloadgentoo-2-81f18e960d17b4b2ce08eef3b1a96bdb33379df7.tar.gz
gentoo-2-81f18e960d17b4b2ce08eef3b1a96bdb33379df7.tar.bz2
gentoo-2-81f18e960d17b4b2ce08eef3b1a96bdb33379df7.zip
Version bump, wrt bug #482152. Sync live ebuild
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/ChangeLog8
-rw-r--r--app-admin/ansible/ansible-1.2.3.ebuild62
-rw-r--r--app-admin/ansible/ansible-9999.ebuild18
3 files changed, 80 insertions, 8 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index c62048f370f4..16fee543526b 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.23 2013/08/24 05:22:39 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.24 2013/09/03 15:11:14 pinkbyte Exp $
+
+*ansible-1.2.3 (03 Sep 2013)
+
+ 03 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> +ansible-1.2.3.ebuild,
+ ansible-9999.ebuild:
+ Version bump, wrt bug #482152. Sync live ebuild
24 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> -ansible-1.0.ebuild,
-ansible-1.1.ebuild:
diff --git a/app-admin/ansible/ansible-1.2.3.ebuild b/app-admin/ansible/ansible-1.2.3.ebuild
new file mode 100644
index 000000000000..a9309d49a979
--- /dev/null
+++ b/app-admin/ansible/ansible-1.2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.2.3.ebuild,v 1.1 2013/09/03 15:11:14 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.cc/"
+SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/nose
+ dev-vcs/git
+ )"
+RDEPEND="
+ dev-python/jinja
+ dev-python/pyyaml
+ dev-python/paramiko
+ net-misc/sshpass
+ virtual/ssh
+"
+
+DOC_CONTENTS="You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/doc/${P}/examples\n\n
+You have to create ansible hosts file!\n
+More info on http://ansible.cc/docs/gettingstarted.html"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # Skip tests which need ssh access
+ sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
+}
+
+python_test() {
+ make tests || die "tests failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ # Hint: do not install example config files into /etc
+ # let this choice to user
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index dc3f543e281f..b9bc3224f97a 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.11 2013/07/16 12:23:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.12 2013/09/03 15:11:13 pinkbyte Exp $
EAPI="5"
@@ -37,19 +37,18 @@ Examples of config files installed in /usr/share/doc/${P}/examples\n\n
You have to create ansible hosts file!\n
More info on http://ansible.cc/docs/gettingstarted.html"
-src_prepare() {
- distutils-r1_src_prepare
+python_prepare_all() {
+ distutils-r1_python_prepare_all
# Skip tests which need ssh access
sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
}
-src_test() {
+python_test() {
make tests || die "tests failed"
}
-src_install() {
- distutils-r1_src_install
- readme.gentoo_create_doc
+python_install_all() {
+ distutils-r1_python_install_all
doman docs/man/man1/*.1
dodoc -r examples
@@ -59,3 +58,8 @@ src_install() {
newenvd "${FILESDIR}"/${PN}.env 95ansible
}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}