summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 13:11:31 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 13:11:31 +0000
commite9ed21a9b4898bb276be1fd478ef10142f07e399 (patch)
tree8327685eedd9c77c9cd297367d721f5ae9d4bc00 /app-accessibility
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo in bug... (diff)
downloadgentoo-2-e9ed21a9b4898bb276be1fd478ef10142f07e399.tar.gz
gentoo-2-e9ed21a9b4898bb276be1fd478ef10142f07e399.tar.bz2
gentoo-2-e9ed21a9b4898bb276be1fd478ef10142f07e399.zip
Bump to 3.0.3, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/ChangeLog7
-rw-r--r--app-accessibility/orca/orca-3.0.3.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index 485ec84ea2ed..2bcb2d5cd96e 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.101 2011/03/22 20:03:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.102 2011/08/16 13:11:31 nirbheek Exp $
+
+*orca-3.0.3 (16 Aug 2011)
+
+ 16 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +orca-3.0.3.ebuild:
+ Bump to 3.0.3, from gnome overlay for GNOME 3
22 Mar 2011; Brent Baude <ranger@gentoo.org> orca-2.32.1.ebuild:
Marking orca-2.32.1 ppc stable for bug 353436
diff --git a/app-accessibility/orca/orca-3.0.3.ebuild b/app-accessibility/orca/orca-3.0.3.ebuild
new file mode 100644
index 000000000000..05c385ba2ebf
--- /dev/null
+++ b/app-accessibility/orca/orca-3.0.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-3.0.3.ebuild,v 1.1 2011/08/16 13:11:31 nirbheek Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.6"
+# FIXME: multiple python support
+
+inherit gnome2 python
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="http://projects.gnome.org/orca/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+RDEPEND=">=dev-libs/glib-2.10:2
+ >=gnome-extra/at-spi-1.32:1
+ >=gnome-base/orbit-2:2
+ >=dev-python/pyorbit-2.24
+ >=gnome-base/libbonobo-2.24
+ >=dev-python/libbonobo-python-2.24:2
+
+ dev-python/pygobject:2
+ dev-python/pycairo
+ dev-python/pyxdg
+ >=dev-python/dbus-python-0.83
+ >=dev-python/pygtk-2.12:2
+
+ >=dev-python/libwnck-python-2.24
+ >=dev-python/gconf-python-2.24:2
+ >=dev-python/libgnome-python-2.14:2
+
+ >=app-accessibility/gnome-speech-0.3.10:1
+ >=app-accessibility/gnome-mag-0.12.5:1"
+
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.17.3
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_configure() {
+ # FIXME: Workaround for bug #325611 until root cause is found
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ # Needed for import pyatspi
+ unset DBUS_SESSION_BUS_ADDRESS
+ PYTHON="$(PYTHON)" gnome2_src_configure
+}
+
+src_compile() {
+ # FIXME: Workaround for bug #325611 until root cause is found
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "${PN}"
+}