summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2014-08-13 18:44:41 +0000
committerChristopher Brannon <teiresias@gentoo.org>2014-08-13 18:44:41 +0000
commit9fa1b402c56c9b3e6aea59ef4dea988b849fdfbc (patch)
treedd02b52b6efccd9c5a825c023845c94359bd28c2 /app-accessibility
parentAdd ~sparc wrt #468536 (diff)
downloadgentoo-2-9fa1b402c56c9b3e6aea59ef4dea988b849fdfbc.tar.gz
gentoo-2-9fa1b402c56c9b3e6aea59ef4dea988b849fdfbc.tar.bz2
gentoo-2-9fa1b402c56c9b3e6aea59ef4dea988b849fdfbc.zip
Fix building with +java USE flag.
Yes, I broke it when I converted this to use python-r1! Argh! Closes bug #519840. (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog7
-rw-r--r--app-accessibility/brltty/brltty-5.0-r3.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index 73e679a079b9..a04abc43e981 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.151 2014/08/06 21:30:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.152 2014/08/13 18:44:41 teiresias Exp $
+
+ 13 Aug 2014; Christopher Brannon <teiresias@gentoo.org> brltty-5.0-r3.ebuild:
+ Fix building with +java USE flag.
+
+ I broke it when I converted the ebuild to use python-r1.
06 Aug 2014; Jeroen Roovers <jer@gentoo.org> brltty-5.0-r3.ebuild:
Stable for HPPA (bug #518990).
diff --git a/app-accessibility/brltty/brltty-5.0-r3.ebuild b/app-accessibility/brltty/brltty-5.0-r3.ebuild
index 64bc5bdb0f39..7c29e924dc9b 100644
--- a/app-accessibility/brltty/brltty-5.0-r3.ebuild
+++ b/app-accessibility/brltty/brltty-5.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-5.0-r3.ebuild,v 1.2 2014/08/06 21:30:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-5.0-r3.ebuild,v 1.3 2014/08/13 18:44:41 teiresias Exp $
EAPI=5
@@ -123,7 +123,7 @@ src_compile() {
if use python; then
python_build() {
cd "Bindings/Python" || die
- emake
+ emake
}
python_foreach_impl run_in_build_dir python_build
fi
@@ -138,7 +138,8 @@ src_install() {
if use python; then
python_install() {
- emake install
+ cd "Bindings/Python" || die
+ emake install
}
python_foreach_impl run_in_build_dir python_install
fi