summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-21 20:19:15 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-21 20:19:15 +0000
commit18a33b70de969e4c60096881f8a35e7fe3e67b2c (patch)
tree85be6066b475b15d7073664666e89360fc83c3bd /app-accessibility
parentAdd temporary directory for tex generated fonts (bug #473896) (diff)
downloadgentoo-2-18a33b70de969e4c60096881f8a35e7fe3e67b2c.tar.gz
gentoo-2-18a33b70de969e4c60096881f8a35e7fe3e67b2c.tar.bz2
gentoo-2-18a33b70de969e4c60096881f8a35e7fe3e67b2c.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog8
-rw-r--r--app-accessibility/brltty/brltty-4.5.ebuild144
-rw-r--r--app-accessibility/brltty/files/brltty-4.5-fix-ldflags.patch56
3 files changed, 207 insertions, 1 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index eb7f55b52310..afacd1e81977 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.127 2013/06/18 16:51:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.128 2013/06/21 20:19:15 vapier Exp $
+
+*brltty-4.5 (21 Jun 2013)
+
+ 21 Jun 2013; Mike Frysinger <vapier@gentoo.org> +brltty-4.5.ebuild,
+ +files/brltty-4.5-fix-ldflags.patch:
+ Version bump.
18 Jun 2013; Mike Frysinger <vapier@gentoo.org> brltty-4.2-r1.ebuild:
Add arm love.
diff --git a/app-accessibility/brltty/brltty-4.5.ebuild b/app-accessibility/brltty/brltty-4.5.ebuild
new file mode 100644
index 000000000000..dfdaac298d44
--- /dev/null
+++ b/app-accessibility/brltty/brltty-4.5.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.5.ebuild,v 1.1 2013/06/21 20:19:15 vapier Exp $
+
+EAPI="4"
+FINDLIB_USE="ocaml"
+
+inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
+ autotools udev
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
+SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
+ java +learn-mode +midi ncurses nls ocaml +pcm python usb +speech
+ tcl X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api )
+ tcl? ( api )"
+
+COMMON_DEP="bluetooth? ( net-wireless/bluez )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu )
+ ncurses? ( sys-libs/ncurses )
+ nls? ( virtual/libintl )
+ python? ( >=dev-python/pyrex-0.9.4.1 )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+ usb? ( virtual/libusb:0 )
+ X? ( x11-libs/libXaw )"
+DEPEND="virtual/pkgconfig
+ java? ( >=virtual/jdk-1.4 )
+ ${COMMON_DEP}"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ ${COMMON_DEP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.5-fix-ldflags.patch
+
+ java-pkg-opt-2_src_prepare
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+}
+
+src_configure() {
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ econf \
+ --prefix=/ \
+ --includedir=/usr/include \
+ --localstatedir=/var \
+ --disable-stripping \
+ --with-install-root="${D}" \
+ $(use_enable api) \
+ $(use_enable beeper beeper-support) \
+ $(use_enable contracted-braille) \
+ $(use_enable fm fm-support) \
+ $(use_enable gpm) \
+ $(use_enable iconv) \
+ $(use_enable icu) \
+ $(use_enable java java-bindings) \
+ $(use_enable learn-mode) \
+ $(use_enable midi midi-support) \
+ $(use_enable nls i18n) \
+ $(use_enable ocaml ocaml-bindings) \
+ $(use_enable pcm pcm-support) \
+ $(use_enable python python-bindings) \
+ $(use_enable speech speech-support) \
+ $(use_enable tcl tcl-bindings) \
+ $(use_enable X x) \
+ $(use_with bluetooth bluetooth-package) \
+ $(use_with ncurses curses) \
+ $(use_with usb usb-package)
+}
+
+src_compile() {
+ local JAVAC_CONF=""
+ local OUR_JNI_FLAGS=""
+ if use java; then
+ OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ # workaround for parallel build failure, bug #340903.
+ emake -j1 JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake OCAML_LDCONF= install
+
+ if use java; then
+ # make install puts the _java.so there, and no it's not $(get_libdir)
+ rm -rf "${D}/usr/lib/java"
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ udev_newrules Hotplug/udev.rules 70-brltty.rules
+ newinitd "${FILESDIR}"/brltty.rc brltty
+
+ libdir="$(get_libdir)"
+ mkdir -p "${D}"/usr/${libdir}/
+ mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+
+ cd Documents
+ mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt
+ mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt
+ mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt
+ dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
+ dohtml -r Manual-BRLTTY
+ if use doc; then
+ dohtml -r Manual-BrlAPI
+ dodoc BrlAPI-*.txt
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog please be sure "${ROOT}"etc/brltty.conf is correct for your system.
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/files/brltty-4.5-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-4.5-fix-ldflags.patch
new file mode 100644
index 000000000000..e60ea9a4e509
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-4.5-fix-ldflags.patch
@@ -0,0 +1,56 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -377,7 +377,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
+- brltty_mkmod_ld_make="-shared"
++ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
+ ;;
+ solaris*)
+ brltty_mkmod_ld_make="-G"
+@@ -404,7 +404,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
++ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
+ else
+ brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
+ fi])
+@@ -414,7 +414,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
+- brltty_mklib_ld_make="-shared"
++ brltty_mklib_ld_make="-shared ${LDFLAGS}"
+ brltty_mklib_ld_options="-soname"
+ ;;
+ solaris*)
+@@ -449,7 +449,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
++ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
+ else
+ brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
+ fi])
+--- a/Bindings/OCaml/Makefile.in
++++ b/Bindings/OCaml/Makefile.in
+@@ -55,13 +55,13 @@
+ all : $(OCAML_FILES)
+
+ $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
+- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
+
+ $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
+ $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
+
+ $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
+- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
+
+ brlapi.cmi: brlapi.mli
+ $(OCAMLC) -o $@ -c brlapi.mli