summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:28:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:28:21 +0000
commit2f6ad527097020714d82fcdca0dab1f7677ff905 (patch)
tree7429db552dea65081216dcfbb266764697db7fb9 /app-accessibility/epos
parentFix building with GCC 4.5+ wrt #318409. (diff)
downloadgentoo-2-2f6ad527097020714d82fcdca0dab1f7677ff905.tar.gz
gentoo-2-2f6ad527097020714d82fcdca0dab1f7677ff905.tar.bz2
gentoo-2-2f6ad527097020714d82fcdca0dab1f7677ff905.zip
Fix building with GCC 4.5+ wrt #318585 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility/epos')
-rw-r--r--app-accessibility/epos/ChangeLog6
-rw-r--r--app-accessibility/epos/epos-2.5.37-r1.ebuild10
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc45.patch15
3 files changed, 26 insertions, 5 deletions
diff --git a/app-accessibility/epos/ChangeLog b/app-accessibility/epos/ChangeLog
index dfa3543470d6..7ac2e498d1de 100644
--- a/app-accessibility/epos/ChangeLog
+++ b/app-accessibility/epos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/epos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/ChangeLog,v 1.39 2010/01/19 01:40:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/ChangeLog,v 1.40 2010/05/06 11:28:21 ssuominen Exp $
+
+ 06 May 2010; Samuli Suominen <ssuominen@gentoo.org> epos-2.5.37-r1.ebuild,
+ +files/epos-2.5.37-gcc45.patch:
+ Fix building with GCC 4.5+ wrt #318585 by Kacper Kowalik.
19 Jan 2010; Jeroen Roovers <jer@gentoo.org> epos-2.5.37-r1.ebuild:
Stable for HPPA too.
diff --git a/app-accessibility/epos/epos-2.5.37-r1.ebuild b/app-accessibility/epos/epos-2.5.37-r1.ebuild
index a30b6cb0bf71..7fc77faa709e 100644
--- a/app-accessibility/epos/epos-2.5.37-r1.ebuild
+++ b/app-accessibility/epos/epos-2.5.37-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/epos-2.5.37-r1.ebuild,v 1.13 2010/01/19 01:40:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/epos-2.5.37-r1.ebuild,v 1.14 2010/05/06 11:28:20 ssuominen Exp $
inherit eutils autotools
@@ -18,10 +18,12 @@ RDEPEND=""
src_unpack() {
unpack ${A}
-
cd "${S}"
- epatch "${FILESDIR}/${P}-gcc43.patch"
- sed -i -e "s/CCC/#CCC/" configure.ac
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
+
+ sed -i -e "s/CCC/#CCC/" configure.ac || die
eautoreconf
}
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc45.patch b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
new file mode 100644
index 000000000000..70af1db94407
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318585
+
+--- src/nnet/neural_parse.yy
++++ src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+