summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 07:48:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 07:48:43 +0000
commite1a82a18e15ae37757064898e1ddc638e2600ae1 (patch)
tree681df1be65723f82112017b3cd350aff0baef5ab
parentBump (diff)
downloadgentoo-2-e1a82a18e15ae37757064898e1ddc638e2600ae1.tar.gz
gentoo-2-e1a82a18e15ae37757064898e1ddc638e2600ae1.tar.bz2
gentoo-2-e1a82a18e15ae37757064898e1ddc638e2600ae1.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/wtf-peewee/ChangeLog7
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/wtf-peewee/ChangeLog b/dev-python/wtf-peewee/ChangeLog
index 4c7413e36207..697c3eae175f 100644
--- a/dev-python/wtf-peewee/ChangeLog
+++ b/dev-python/wtf-peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtf-peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.6 2014/05/25 03:28:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.7 2014/05/26 07:48:43 patrick Exp $
+
+*wtf-peewee-0.2.2 (26 May 2014)
+
+ 26 May 2014; Patrick Lauer <patrick@gentoo.org> +wtf-peewee-0.2.2.ebuild:
+ Bump
25 May 2014; Ian Delaney <idella4@gentoo.org> wtf-peewee-0.2.1.ebuild:
unrestrict & upgrade test phase, add IUSE examples
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.2.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.2.ebuild
new file mode 100644
index 000000000000..22306b3d5c97
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.2.2.ebuild,v 1.1 2014/05/26 07:48:43 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( "${RDEPEND}" )"
+
+python_prepare_all() {
+ # https://github.com/coleifer/peewee/issues/361
+ sed -e s':test_choices:_&:' \
+ -e s':test_null_form_saving:_&:' \
+ -i "${PN/\-/}"/tests.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}