summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-17 07:56:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-17 07:56:14 +0000
commitd6da45d477c803e57355cd4cf3edb6e6b42e2a6e (patch)
tree32eac7f6461dd452b1aa5b7bd9c7445e822f9d2f
parentUSE="static-libs" and remove unnecessary libtool file in favour of pkg-config... (diff)
downloadgentoo-2-d6da45d477c803e57355cd4cf3edb6e6b42e2a6e.tar.gz
gentoo-2-d6da45d477c803e57355cd4cf3edb6e6b42e2a6e.tar.bz2
gentoo-2-d6da45d477c803e57355cd4cf3edb6e6b42e2a6e.zip
initial commit with modified ebuild submitted by Vicente Olivert Riera (bug #436552)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-kids/memonix/ChangeLog11
-rw-r--r--games-kids/memonix/memonix-1.6.ebuild48
-rw-r--r--games-kids/memonix/metadata.xml5
3 files changed, 64 insertions, 0 deletions
diff --git a/games-kids/memonix/ChangeLog b/games-kids/memonix/ChangeLog
new file mode 100644
index 000000000000..f344d39ad67d
--- /dev/null
+++ b/games-kids/memonix/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-kids/memonix
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/memonix/ChangeLog,v 1.1 2012/11/17 07:56:14 mr_bones_ Exp $
+
+*memonix-1.6 (17 Nov 2012)
+
+ 17 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +memonix-1.6.ebuild,
+ +metadata.xml:
+ initial commit with modified ebuild submitted by Vicente Olivert Riera (bug
+ #436552)
+
diff --git a/games-kids/memonix/memonix-1.6.ebuild b/games-kids/memonix/memonix-1.6.ebuild
new file mode 100644
index 000000000000..4a899165ae95
--- /dev/null
+++ b/games-kids/memonix/memonix-1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/memonix/memonix-1.6.ebuild,v 1.1 2012/11/17 07:56:14 mr_bones_ Exp $
+
+EAPI=4
+inherit cmake-utils games
+
+DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
+HOMEPAGE="http://www.viewizard.com/memonix/"
+SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="Memonix"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[audio,opengl,video]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[vorbis]
+ !games-kids/memonix-bin"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/MemonixSourceCode
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)"
+ doexe ../${P}_build/Memonix
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../gamedata.vfs
+
+ games_make_wrapper ${PN} "$(games_get_libdir)"/Memonix "${GAMES_DATADIR}"/${PN}
+
+ newicon ../icon48.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dodoc ReadMe.txt
+
+ prepgamesdirs
+}
diff --git a/games-kids/memonix/metadata.xml b/games-kids/memonix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-kids/memonix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>