summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:19:12 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:19:12 +0000
commitd6bf1e11d34ebca8649b7ed9b29447afb44d4dd4 (patch)
tree11e92c147796ec4fadf27cc1f2d314f01b155c1a
parent* bump, bug #180109 (diff)
downloadgentoo-2-d6bf1e11d34ebca8649b7ed9b29447afb44d4dd4.tar.gz
gentoo-2-d6bf1e11d34ebca8649b7ed9b29447afb44d4dd4.tar.bz2
gentoo-2-d6bf1e11d34ebca8649b7ed9b29447afb44d4dd4.zip
* bump, bug #180109
(Portage version: 2.1.3_rc6)
-rw-r--r--dev-php5/xdebug/ChangeLog8
-rw-r--r--dev-php5/xdebug/files/digest-xdebug-2.0.0_rc43
-rw-r--r--dev-php5/xdebug/xdebug-2.0.0_rc4.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/dev-php5/xdebug/ChangeLog b/dev-php5/xdebug/ChangeLog
index d98f4666d837..f1e73fe19ed5 100644
--- a/dev-php5/xdebug/ChangeLog
+++ b/dev-php5/xdebug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/xdebug
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.12 2007/03/18 03:08:30 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.13 2007/06/30 17:19:12 voxus Exp $
+
+*xdebug-2.0.0_rc4 (30 Jun 2007)
+
+ 30 Jun 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +xdebug-2.0.0_rc4.ebuild:
+ Version bump, closing bug #180109.
18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> xdebug-2.0.0_rc3.ebuild:
Fix DEPs.
diff --git a/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc4 b/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc4
new file mode 100644
index 000000000000..ade274eed74c
--- /dev/null
+++ b/dev-php5/xdebug/files/digest-xdebug-2.0.0_rc4
@@ -0,0 +1,3 @@
+MD5 19e614105e96741b0a030ece233a8ced xdebug-2.0.0RC4.tgz 269219
+RMD160 8d37414e3efc1aff55582781d8c2e4c4bdccfeec xdebug-2.0.0RC4.tgz 269219
+SHA256 7b4b397aa9e6f52e81ad188e42cb5332294b9748b562159edfc2b83b808eac85 xdebug-2.0.0RC4.tgz 269219
diff --git a/dev-php5/xdebug/xdebug-2.0.0_rc4.ebuild b/dev-php5/xdebug/xdebug-2.0.0_rc4.ebuild
new file mode 100644
index 000000000000..3b2b5221bae8
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.0.0_rc4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.0.0_rc4.ebuild,v 1.1 2007/06/30 17:19:12 voxus Exp $
+
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DEPEND="!dev-php5/ZendOptimizer"
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php NEWS README Changelog CREDITS LICENSE
+
+ php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
+}