summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-13 14:06:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-13 14:06:56 +0000
commitd1a8f56553fd676f3ed98dc91518a210e847f38d (patch)
tree1dea1360e8c1040f16f393fcd8ed484ed7871d33
parentRemoved uneeded dep on sexy-python, backport clickable link in status message... (diff)
downloadgentoo-2-d1a8f56553fd676f3ed98dc91518a210e847f38d.tar.gz
gentoo-2-d1a8f56553fd676f3ed98dc91518a210e847f38d.tar.bz2
gentoo-2-d1a8f56553fd676f3ed98dc91518a210e847f38d.zip
Version bump to latest. Drop older. Fixes bug #363437
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
-rw-r--r--media-libs/phonon-gstreamer/ChangeLog9
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.5.0.ebuild (renamed from media-libs/phonon-gstreamer/phonon-gstreamer-4.4.4.ebuild)20
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild22
3 files changed, 39 insertions, 12 deletions
diff --git a/media-libs/phonon-gstreamer/ChangeLog b/media-libs/phonon-gstreamer/ChangeLog
index 2098a2f2f445..247a79588b95 100644
--- a/media-libs/phonon-gstreamer/ChangeLog
+++ b/media-libs/phonon-gstreamer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/phonon-gstreamer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.2 2011/04/03 18:23:02 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.3 2011/04/13 14:06:56 scarabeus Exp $
+
+*phonon-gstreamer-4.5.0 (13 Apr 2011)
+
+ 13 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -phonon-gstreamer-4.4.4.ebuild, +phonon-gstreamer-4.5.0.ebuild,
+ phonon-gstreamer-9999.ebuild:
+ Version bump to latest. Drop older. Fixes bug #363437
03 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
phonon-gstreamer-4.4.4.ebuild, phonon-gstreamer-9999.ebuild:
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.4.4.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.5.0.ebuild
index b041d03df0a9..d4252a0c6020 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-4.4.4.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.5.0.ebuild
@@ -1,19 +1,27 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-4.4.4.ebuild,v 1.2 2011/04/03 18:23:02 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-4.5.0.ebuild,v 1.1 2011/04/13 14:06:56 scarabeus Exp $
-EAPI="3"
+EAPI=4
+
+[[ ${PV} == *9999 ]] && git_eclass="git"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}"
MY_PN="phonon-backend-gstreamer"
+MY_P=${MY_PN}-${PV}
-inherit cmake-utils
+inherit cmake-utils ${git_eclass}
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer"
-SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_PN}-${PV}.tar.bz2"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
SLOT="0"
IUSE="alsa debug"
@@ -31,7 +39,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
"
-S="${WORKDIR}/${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
src_configure() {
local mycmakeargs=(
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index a5a2314d6747..443c983ea209 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -1,17 +1,27 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild,v 1.2 2011/04/03 18:23:02 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild,v 1.3 2011/04/13 14:06:56 scarabeus Exp $
-EAPI="3"
+EAPI=4
-inherit cmake-utils git
+[[ ${PV} == *9999 ]] && git_eclass="git"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+
+MY_PN="phonon-backend-gstreamer"
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils ${git_eclass}
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer"
-EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
LICENSE="LGPL-2.1"
-KEYWORDS=""
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
SLOT="0"
IUSE="alsa debug"
@@ -29,6 +39,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
"
+S="${WORKDIR}/${MY_P}"
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with alsa)