summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-25 18:47:03 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-25 18:47:03 +0000
commitd0594c8cf330ea90e518dc312cd508c14e768100 (patch)
tree186ffe8ba4ad70b694c891b05d79c9df04a5a39f
parentVersion bumped. Security fix. (diff)
downloadgentoo-2-d0594c8cf330ea90e518dc312cd508c14e768100.tar.gz
gentoo-2-d0594c8cf330ea90e518dc312cd508c14e768100.tar.bz2
gentoo-2-d0594c8cf330ea90e518dc312cd508c14e768100.zip
Version bumped. Security fix.
-rw-r--r--app-misc/gallery/ChangeLog9
-rw-r--r--app-misc/gallery/Manifest4
-rw-r--r--app-misc/gallery/files/digest-gallery-1.4.1_p11
-rw-r--r--app-misc/gallery/gallery-1.4.1_p1.ebuild66
4 files changed, 76 insertions, 4 deletions
diff --git a/app-misc/gallery/ChangeLog b/app-misc/gallery/ChangeLog
index 21d83e03d1cb..b762cb586935 100644
--- a/app-misc/gallery/ChangeLog
+++ b/app-misc/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gallery
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/ChangeLog,v 1.20 2003/12/15 19:57:18 stuart Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/ChangeLog,v 1.21 2004/01/25 18:46:47 mholzer Exp $
+
+*gallery-1.4.1_p1 (25 Jan 2004)
+
+ 25 Jan 2004; Martin Holzer <mholzer@gentoo.org> gallery-1.4.1_p1.ebuild:
+ Version bumped. Security fix.
15 Dec 2003; Stuart Herbert <stuart@gentoo.org> gallery-1.4.1.ebuild:
Fix for bug #32636
diff --git a/app-misc/gallery/Manifest b/app-misc/gallery/Manifest
index a812837882ad..daaaf4755409 100644
--- a/app-misc/gallery/Manifest
+++ b/app-misc/gallery/Manifest
@@ -1,8 +1,8 @@
-MD5 54c716b85f1078e72f02fd8a52798b5f ChangeLog 2328
+MD5 c085fa15decaa309c7b04a65c5fe4330 ChangeLog 2329
MD5 9767e4c8647efe180d0cc619236ad746 gallery-1.4.1.ebuild 1773
MD5 7ade084ecabde894f7f88fb29e0eea08 gallery-1.4_p2.ebuild 2431
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
-MD5 c7d98c03dcd4401169d2626ecd330c1b gallery-1.4.1_p1.ebuild 1788
+MD5 848684248a6ded33e710628847fc2cba gallery-1.4.1_p1.ebuild 1792
MD5 44ef29bfa9165ad28d6de638d9c64cb5 files/digest-gallery-1.4.1 65
MD5 a9b8e52b9d14c6b3a74d3b71cb0dc038 files/digest-gallery-1.4_p2 68
MD5 d4812c8c0c1fad4c00cda3e8ad7bbe8a files/digest-gallery-1.4.1_p1 69
diff --git a/app-misc/gallery/files/digest-gallery-1.4.1_p1 b/app-misc/gallery/files/digest-gallery-1.4.1_p1
new file mode 100644
index 000000000000..aae39072b2e1
--- /dev/null
+++ b/app-misc/gallery/files/digest-gallery-1.4.1_p1
@@ -0,0 +1 @@
+MD5 be41eceb5a5d3c545c72a35c3a4876c2 gallery-1.4.1-pl1.tar.gz 928899
diff --git a/app-misc/gallery/gallery-1.4.1_p1.ebuild b/app-misc/gallery/gallery-1.4.1_p1.ebuild
new file mode 100644
index 000000000000..0c4cb8dd0977
--- /dev/null
+++ b/app-misc/gallery/gallery-1.4.1_p1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/gallery-1.4.1_p1.ebuild,v 1.1 2004/01/25 18:46:47 mholzer Exp $
+
+inherit webapp-apache
+
+MY_P=${P/_p/-pl}
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator."
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="x86 ppc sparc alpha mips hppa amd64"
+DEPEND=">=net-www/apache-1.3.24-r1
+ >=dev-php/mod_php-4.1.2-r5
+ >=media-gfx/jhead-1.6
+ >=media-libs/netpbm-9.12
+ >=media-gfx/imagemagick-5.4.9.1-r1"
+
+S=${WORKDIR}/${PN}
+
+webapp-detect || NO_WEBSERVER=1
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+ dodoc AUTHORS ChangeLog README LICENSE.txt
+ rm -rf ChangeLog
+
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+
+ #dohtml docs/*
+}
+
+pkg_postinst() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+# chown -R apache:apache ${DST_PATH}
+ chown root:root ${destdir}/secure.sh ${destdir}/configure.sh
+ chmod 700 ${destdir}/secure.sh ${destdir}/configure.sh
+
+ einfo
+ einfo "For new installations point your browser to "
+ einfo "http://www.yourhost.com/gallery/setup/"
+ einfo "and follow the instructions."
+ einfo "--------------------------------------------"
+ einfo "For upgrades, just run"
+ einfo "# cd ${destdir}"
+ einfo "# sh ./secure.sh"
+ einfo
+}