summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2007-03-12 11:57:16 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2007-03-12 11:57:16 +0000
commitbfc8a67a5d6d7ad1425746c63acf3d54420cb6e6 (patch)
treee1322fd95f63c40ab2876f029194d2365970bd26
parentPC died just before sending Manifest. (diff)
downloadgentoo-2-bfc8a67a5d6d7ad1425746c63acf3d54420cb6e6.tar.gz
gentoo-2-bfc8a67a5d6d7ad1425746c63acf3d54420cb6e6.tar.bz2
gentoo-2-bfc8a67a5d6d7ad1425746c63acf3d54420cb6e6.zip
Fix for bug 169678.
(Portage version: 2.1.2.2)
-rw-r--r--app-misc/mc/ChangeLog6
-rw-r--r--app-misc/mc/files/mc-4.6.1-charset-locale-aliases.patch40
-rw-r--r--app-misc/mc/mc-4.6.1-r3.ebuild8
3 files changed, 49 insertions, 5 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 378696e361c6..73b202b7953a 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/mc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.113 2007/01/28 05:19:46 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.114 2007/03/12 11:57:16 the_paya Exp $
+
+ 12 Mar 2007; Javier Villavicencio <the_paya@gentoo.org>
+ +files/mc-4.6.1-charset-locale-aliases.patch, mc-4.6.1-r3.ebuild:
+ Correctly generate charset.alias. Fixes bug 169678.
28 Jan 2007; Marius Mauch <genone@gentoo.org> mc-4.6.1.ebuild,
mc-4.6.1-r3.ebuild:
diff --git a/app-misc/mc/files/mc-4.6.1-charset-locale-aliases.patch b/app-misc/mc/files/mc-4.6.1-charset-locale-aliases.patch
new file mode 100644
index 000000000000..53aedd0d4a99
--- /dev/null
+++ b/app-misc/mc/files/mc-4.6.1-charset-locale-aliases.patch
@@ -0,0 +1,40 @@
+diff -ruN mc-4.6.1.orig/intl/Makefile.in mc-4.6.1/intl/Makefile.in
+--- mc-4.6.1.orig/intl/Makefile.in 2007-03-06 22:31:02.000000000 +0300
++++ mc-4.6.1/intl/Makefile.in 2007-03-06 22:38:52.000000000 +0300
+@@ -156,12 +156,7 @@
+ test @GLIBC21@ != no || $(mkinstalldirs) $(DESTDIR)$(libdir); \
+ temp=$(DESTDIR)$(libdir)/t-charset.alias; \
+ dest=$(DESTDIR)$(libdir)/charset.alias; \
+- if test -f $(DESTDIR)$(libdir)/charset.alias; then \
+- orig=$(DESTDIR)$(libdir)/charset.alias; \
+- sed -f ref-add.sed $$orig > $$temp; \
+- $(INSTALL_DATA) $$temp $$dest; \
+- rm -f $$temp; \
+- else \
++ if ! test -f $(libdir)/charset.alias; then \
+ if test @GLIBC21@ = no; then \
+ orig=charset.alias; \
+ sed -f ref-add.sed $$orig > $$temp; \
+@@ -170,14 +165,14 @@
+ fi; \
+ fi; \
+ $(mkinstalldirs) $(DESTDIR)$(localedir); \
+- test -f $(DESTDIR)$(localedir)/locale.alias \
+- && orig=$(DESTDIR)$(localedir)/locale.alias \
+- || orig=$(srcdir)/locale.alias; \
+- temp=$(DESTDIR)$(localedir)/t-locale.alias; \
+- dest=$(DESTDIR)$(localedir)/locale.alias; \
+- sed -f ref-add.sed $$orig > $$temp; \
+- $(INSTALL_DATA) $$temp $$dest; \
+- rm -f $$temp; \
++ if ! test -f $(localedir)/locale.alias; then \
++ orig=$(srcdir)/locale.alias; \
++ temp=$(DESTDIR)$(localedir)/t-locale.alias; \
++ dest=$(DESTDIR)$(localedir)/locale.alias; \
++ sed -f ref-add.sed $$orig > $$temp; \
++ $(INSTALL_DATA) $$temp $$dest; \
++ rm -f $$temp; \
++ fi; \
+ else \
+ : ; \
+ fi
diff --git a/app-misc/mc/mc-4.6.1-r3.ebuild b/app-misc/mc/mc-4.6.1-r3.ebuild
index 81bd1ba30eff..3e96eb92fd0d 100644
--- a/app-misc/mc/mc-4.6.1-r3.ebuild
+++ b/app-misc/mc/mc-4.6.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.1-r3.ebuild,v 1.2 2007/01/28 05:19:47 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.1-r3.ebuild,v 1.3 2007/03/12 11:57:16 the_paya Exp $
inherit flag-o-matic eutils
@@ -65,6 +65,9 @@ src_unpack() {
# - not using bindnow-flags() because cons.saver is only built on GNU/Linux
sed -i -e "s:^\(cons_saver_LDADD = .*\):\1 -Wl,-z,now:" \
src/Makefile.in
+ # Correctly generate charset.alias.
+ # Fixes bugs 71275, 105960 and 169678
+ epatch ${FILESDIR}/${P}-charset-locale-aliases.patch
}
src_compile() {
@@ -131,9 +134,6 @@ src_install() {
doins ${FILESDIR}/ebuild.syntax
cd ${D}/usr/share/mc/syntax
epatch ${FILESDIR}/${PN}-4.6.0-ebuild-syntax.patch
-
- # http://bugs.gentoo.org/show_bug.cgi?id=71275
- rm -f ${D}/usr/share/locale/locale.alias
}
pkg_postinst() {