summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-30 13:51:56 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-07-30 13:51:56 +0000
commitbf019275acaa9b321207ef14d48f007970564cde (patch)
tree7318ecfa81d1efbd46d5201f9bf10d615b1b259d
parentFixed sed in ebuilds which was fixing paths to make package work again. (diff)
downloadgentoo-2-bf019275acaa9b321207ef14d48f007970564cde.tar.gz
gentoo-2-bf019275acaa9b321207ef14d48f007970564cde.tar.bz2
gentoo-2-bf019275acaa9b321207ef14d48f007970564cde.zip
added prefix support (bug #428564)
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
-rw-r--r--x11-libs/vte/ChangeLog6
-rw-r--r--x11-libs/vte/files/vte-0.28.2-interix.patch51
-rw-r--r--x11-libs/vte/vte-0.28.2-r203.ebuild14
-rw-r--r--x11-libs/vte/vte-0.32.2.ebuild12
4 files changed, 78 insertions, 5 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 707e2f36204d..9f9b6760773e 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.328 2012/07/15 18:42:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.329 2012/07/30 13:51:56 ottxor Exp $
+
+ 30 Jul 2012; Christoph Junghans <ottxor@gentoo.org>
+ +files/vte-0.28.2-interix.patch, vte-0.28.2-r203.ebuild, vte-0.32.2.ebuild:
+ added prefix support (bug #428564)
15 Jul 2012; Raúl Porcel <armin76@gentoo.org> vte-0.28.2-r203.ebuild:
alpha/ia64/sh/sparc stable wrt #410611
diff --git a/x11-libs/vte/files/vte-0.28.2-interix.patch b/x11-libs/vte/files/vte-0.28.2-interix.patch
new file mode 100644
index 000000000000..c54d46ebc3dc
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.28.2-interix.patch
@@ -0,0 +1,51 @@
+reported upstream: https://bugzilla.gnome.org/show_bug.cgi?id=652290
+
+diff -ru vte-0.26.2.orig/configure.in vte-0.26.2/configure.in
+--- vte-0.26.2.orig/configure.in 2011-08-17 08:30:55 +0200
++++ vte-0.26.2/configure.in 2011-08-17 08:35:42 +0200
+@@ -362,7 +362,11 @@
+ AC_DEFINE(HAVE_RECVMSG,1,[Define if you have the recvmsg function.])
+ fi
+ AC_CHECK_FUNC(floor,,AC_CHECK_LIB(m,floor,LIBS=["$LIBS -lm"]))
+-AC_CHECK_FUNCS([ceil floor])
++dnl if the first check didn't find floor, it caches the "no" value,
++dnl and doesn't recheck. this makes the below check fail always on
++dnl systems with floor in -lm. thus we unset the chached result.
++unset ac_cv_func_floor
++AC_CHECK_FUNCS([ceil floor round])
+
+ # Look for tgetent
+
+--- vte-0.26.2.orig/configure 2012-04-30 20:02:55.000000000 +0200
++++ vte-0.26.2/configure 2012-04-30 20:03:16.000000000 +0200
+@@ -13277,7 +13277,7 @@
+
+ fi
+
+-for ac_func in ceil floor
++for ac_func in ceil floor round
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
+diff -ru vte-0.26.2.orig/src/vte.c vte-0.26.2/src/vte.c
+--- vte-0.26.2.orig/src/vte.c 2011-08-17 08:30:58 +0200
++++ vte-0.26.2/src/vte.c 2011-08-17 08:38:09 +0200
+@@ -63,6 +63,18 @@
+ #include <locale.h>
+ #endif
+
++#ifndef HAVE_ROUND
++# if defined(HAVE_CEIL) && defined(HAVE_FLOOR)
++static inline double round(double x) {
++ if(x - floor(x) < 0.5) {
++ return floor(x);
++ } else {
++ return ceil(x);
++ }
++}
++# endif
++#endif
++
+ #if GTK_CHECK_VERSION (2, 90, 7)
+ #define GDK_KEY(symbol) GDK_KEY_##symbol
+ #else
diff --git a/x11-libs/vte/vte-0.28.2-r203.ebuild b/x11-libs/vte/vte-0.28.2-r203.ebuild
index 19d9a753008c..74607a91999f 100644
--- a/x11-libs/vte/vte-0.28.2-r203.ebuild
+++ b/x11-libs/vte/vte-0.28.2-r203.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.28.2-r203.ebuild,v 1.10 2012/07/15 18:42:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.28.2-r203.ebuild,v 1.11 2012/07/30 13:51:56 ottxor Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -14,7 +14,7 @@ HOMEPAGE="http://git.gnome.org/browse/vte"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-linux"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-linux ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
IUSE="debug doc glade +introspection python"
PDEPEND="x11-libs/gnome-pty-helper"
@@ -46,6 +46,14 @@ pkg_setup() {
$(use_enable introspection)
$(use_enable python)
--with-gtk=2.0"
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ G2CONF="${G2CONF} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
DOCS="AUTHORS ChangeLog HACKING NEWS README"
if use python; then
python_set_active_version 2
@@ -56,6 +64,8 @@ pkg_setup() {
src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=663779
epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=652290
+ epatch "${FILESDIR}"/${PN}-0.28.2-interix.patch
gnome2_src_prepare
}
diff --git a/x11-libs/vte/vte-0.32.2.ebuild b/x11-libs/vte/vte-0.32.2.ebuild
index e4307d418435..98bbbee45974 100644
--- a/x11-libs/vte/vte-0.32.2.ebuild
+++ b/x11-libs/vte/vte-0.32.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.32.2.ebuild,v 1.1 2012/06/16 10:48:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.32.2.ebuild,v 1.2 2012/07/30 13:51:56 ottxor Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -13,7 +13,7 @@ HOMEPAGE="http://git.gnome.org/browse/vte"
LICENSE="LGPL-2"
SLOT="2.90"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~alpha"
IUSE="debug doc glade +introspection"
PDEPEND="x11-libs/gnome-pty-helper"
@@ -43,6 +43,14 @@ pkg_setup() {
$(use_enable debug)
$(use_enable glade glade-catalogue)
$(use_enable introspection)"
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ G2CONF="${G2CONF} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
DOCS="AUTHORS ChangeLog HACKING NEWS README"
}