summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-02-12 21:21:26 +0000
committerMatti Bickel <mabi@gentoo.org>2008-02-12 21:21:26 +0000
commitb8304c393061be68dd052f634d1ded728abba0d8 (patch)
tree0070efb67e22751335ac3577ff5fede37d199fd5
parentVersion bump, mark -alpha/-ia64 since it segfaults, and on amd64 as well (diff)
downloadgentoo-2-b8304c393061be68dd052f634d1ded728abba0d8.tar.gz
gentoo-2-b8304c393061be68dd052f634d1ded728abba0d8.tar.bz2
gentoo-2-b8304c393061be68dd052f634d1ded728abba0d8.zip
revbump, remove older versions
(Portage version: 2.1.4.1)
-rw-r--r--dev-lang/lua/ChangeLog12
-rw-r--r--dev-lang/lua/files/lua-5.1-make.patch15
-rw-r--r--dev-lang/lua/lua-5.1.1-r2.ebuild8
-rw-r--r--dev-lang/lua/lua-5.1.2-r2.ebuild8
-rw-r--r--dev-lang/lua/lua-5.1.2.ebuild96
-rw-r--r--dev-lang/lua/lua-5.1.3.ebuild (renamed from dev-lang/lua/lua-5.1.2-r1.ebuild)14
6 files changed, 32 insertions, 121 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index e55dc3a8f41f..948197e3a8ec 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/lua
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.85 2007/09/18 08:14:28 mabi Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.86 2008/02/12 21:21:25 mabi Exp $
+
+*lua-5.1.3 (11 Feb 2008)
+
+ 11 Feb 2008; Matti Bickel <mabi@gentoo.org> files/lua-5.1-make.patch,
+ lua-5.1.1-r2.ebuild, -lua-5.1.2.ebuild, -lua-5.1.2-r1.ebuild,
+ lua-5.1.2-r2.ebuild, +lua-5.1.3.ebuild:
+ version bump, reduced make patch due to upstream now shipping a more
+ friendly Makefile
*lua-5.1.2-r2 (18 Sep 2007)
diff --git a/dev-lang/lua/files/lua-5.1-make.patch b/dev-lang/lua/files/lua-5.1-make.patch
index fb95d253422d..654d593d634e 100644
--- a/dev-lang/lua/files/lua-5.1-make.patch
+++ b/dev-lang/lua/files/lua-5.1-make.patch
@@ -1,20 +1,5 @@
--- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -22,10 +22,10 @@
- # How to install. You may prefer "install" instead of "cp" if you have it.
- # To remove debug information from binaries, use "install -s" in INSTALL_EXEC.
- #
--INSTALL_EXEC= $(CP)
--INSTALL_DATA= $(CP)
--#INSTALL_EXEC= $(INSTALL) -m 0755
--#INSTALL_DATA= $(INSTALL) -m 0644
-+#INSTALL_EXEC= $(CP)
-+#INSTALL_DATA= $(CP)
-+INSTALL_EXEC= $(INSTALL) -m 0755
-+INSTALL_DATA= $(INSTALL) -m 0644
-
- # Utilities.
- CP= cp
@@ -127,3 +127,22 @@
.PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho newer
diff --git a/dev-lang/lua/lua-5.1.1-r2.ebuild b/dev-lang/lua/lua-5.1.1-r2.ebuild
index fe461ba1e876..b2864b5821ec 100644
--- a/dev-lang/lua/lua-5.1.1-r2.ebuild
+++ b/dev-lang/lua/lua-5.1.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.1-r2.ebuild,v 1.16 2008/01/29 21:24:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.1-r2.ebuild,v 1.17 2008/02/12 21:21:25 mabi Exp $
inherit eutils portability versionator
@@ -23,6 +23,10 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
+ # extra patching not required in lua-5.1.3
+ sed -i -e 's:\(INSTALL_.*\= \$(CP)\):#\1:g' Makefile
+ sed -i -e 's:#\(INSTALL_.*\= \$(INSTALL)\):\1:g' Makefile
+
sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
if ! use readline ; then
diff --git a/dev-lang/lua/lua-5.1.2-r2.ebuild b/dev-lang/lua/lua-5.1.2-r2.ebuild
index 006b81713c02..70e5923eb9c9 100644
--- a/dev-lang/lua/lua-5.1.2-r2.ebuild
+++ b/dev-lang/lua/lua-5.1.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2-r2.ebuild,v 1.2 2008/01/29 21:24:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2-r2.ebuild,v 1.3 2008/02/12 21:21:25 mabi Exp $
inherit eutils portability versionator
@@ -23,6 +23,10 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
+ # extra patching not required in lua-5.1.3
+ sed -i -e 's:\(INSTALL_.*\= \$(CP)\):#\1:g' Makefile
+ sed -i -e 's:#\(INSTALL_.*\= \$(INSTALL)\):\1:g' Makefile
+
# correct lua versioning (bug #173611)
sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:2:1/' src/Makefile
diff --git a/dev-lang/lua/lua-5.1.2.ebuild b/dev-lang/lua/lua-5.1.2.ebuild
deleted file mode 100644
index d4445647e5cf..000000000000
--- a/dev-lang/lua/lua-5.1.2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2.ebuild,v 1.3 2008/01/29 21:24:44 grobian Exp $
-
-inherit eutils portability versionator
-
-DESCRIPTION="A powerful light-weight programming language designed for extending applications"
-HOMEPAGE="http://www.lua.org/"
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="readline static"
-
-DEPEND="readline? ( sys-libs/readline )"
-
-src_unpack() {
- local PATCH_PV=$(get_version_component_range 1-2)
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
-
- sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
-
- if ! use readline ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
- fi
-
- # Using dynamic linked lua is not recommended upstream for performance
- # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
- # Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Note that the lua compiler is build statically anyway
- if use static ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
- fi
-
- # We want packages to find our things...
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-}
-
-src_compile() {
- myflags=
- # what to link to liblua
- liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
-
- # what to link to the executables
- mylibs=
- if use readline; then
- mylibs="-lreadline"
- fi
-
- cd src
- emake CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="/usr/$(get_libdir)/" \
- LUA_LIBS="${mylibs}" \
- LIB_LIBS="${liblibs}" \
- V=${PV} \
- gentoo_all || die "emake failed"
-
- mv lua_test ../test/lua.static
-}
-
-src_install() {
- emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
- V=${PV} gentoo_install \
- || die "emake install gentoo_install failed"
-
- dodoc HISTORY README
- dohtml doc/*.html doc/*.gif
-
- insinto /usr/share/pixmaps
- doins etc/lua.ico
- insinto /usr/$(get_libdir)/pkgconfig
- doins etc/lua.pc
-}
-
-src_test() {
- local positive="bisect cf echo env factorial fib fibfor hello printf sieve
- sort trace-calls trace-globals"
- local negative="readonly"
- local test
-
- cd "${S}"
- for test in ${positive}; do
- test/lua.static test/${test}.lua &> /dev/null || die "test $test failed"
- done
-
- for test in ${negative}; do
- test/lua.static test/${test}.lua &> /dev/null && die "test $test failed"
- done
-}
diff --git a/dev-lang/lua/lua-5.1.2-r1.ebuild b/dev-lang/lua/lua-5.1.3.ebuild
index 6247177105ca..0eb73a9c5be7 100644
--- a/dev-lang/lua/lua-5.1.2-r1.ebuild
+++ b/dev-lang/lua/lua-5.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2-r1.ebuild,v 1.3 2008/01/29 21:24:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3.ebuild,v 1.1 2008/02/12 21:21:25 mabi Exp $
inherit eutils portability versionator
@@ -48,8 +48,12 @@ src_compile() {
myflags=
# what to link to liblua
liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
+ if use ppc-macos; then
+ mycflags="${mycflags} -DLUA_USE_MACOSX"
+ else # building for standard linux (and bsd too)
+ mycflags="${mycflags} -DLUA_USE_LINUX"
+ liblibs="${liblibs} $(dlopen_lib)"
+ fi
# what to link to the executables
mylibs=
@@ -80,6 +84,8 @@ src_install() {
doins etc/lua.ico
insinto /usr/$(get_libdir)/pkgconfig
doins etc/lua.pc
+
+ doman doc/lua.1 doc/luac.1
}
src_test() {