summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-15 04:29:14 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-15 04:29:14 +0000
commita5de03fe23356fe65227f01e70ed2f72fab54bac (patch)
tree65111fba4f6acbf65771b045aed772f4fc253012
parentupdate patch from upstream (diff)
downloadgentoo-2-a5de03fe23356fe65227f01e70ed2f72fab54bac.tar.gz
gentoo-2-a5de03fe23356fe65227f01e70ed2f72fab54bac.tar.bz2
gentoo-2-a5de03fe23356fe65227f01e70ed2f72fab54bac.zip
Fix from upstream for short pipeline execution.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-4.4_alpha-r1.ebuild (renamed from app-shells/bash/bash-4.4_alpha.ebuild)4
-rw-r--r--app-shells/bash/files/bash-4.4-optimize-fork.patch16
3 files changed, 26 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index ddffdbd22ad6..736423bc0d32 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.442 2015/07/13 07:21:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.443 2015/07/15 04:29:14 vapier Exp $
+
+*bash-4.4_alpha-r1 (15 Jul 2015)
+
+ 15 Jul 2015; Mike Frysinger <vapier@gentoo.org> +bash-4.4_alpha-r1.ebuild,
+ +files/bash-4.4-optimize-fork.patch, -bash-4.4_alpha.ebuild:
+ Fix from upstream for short pipeline execution.
13 Jul 2015; Mike Frysinger <vapier@gentoo.org> bash-4.3_p33-r2.ebuild:
Mark sparc stable #548756.
diff --git a/app-shells/bash/bash-4.4_alpha.ebuild b/app-shells/bash/bash-4.4_alpha-r1.ebuild
index 508490d8c17b..d83e0409ed65 100644
--- a/app-shells/bash/bash-4.4_alpha.ebuild
+++ b/app-shells/bash/bash-4.4_alpha-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.4_alpha.ebuild,v 1.1 2015/07/13 04:30:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.4_alpha-r1.ebuild,v 1.1 2015/07/15 04:29:14 vapier Exp $
EAPI="5"
@@ -85,6 +85,8 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/*
+ epatch "${FILESDIR}"/${PN}-4.4-optimize-fork.patch
+
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.4-optimize-fork.patch b/app-shells/bash/files/bash-4.4-optimize-fork.patch
new file mode 100644
index 000000000000..98e83be12f8e
--- /dev/null
+++ b/app-shells/bash/files/bash-4.4-optimize-fork.patch
@@ -0,0 +1,16 @@
+https://lists.gnu.org/archive/html/bug-bash/2015-07/msg00060.html
+
+*** ../bash-4.4-alpha/execute_cmd.c 2015-06-12 17:29:18.000000000 -0400
+--- execute_cmd.c 2015-07-14 08:59:22.000000000 -0400
+***************
+*** 2630,2638 ****
+ if (ignore_return && second)
+ second->flags |= CMD_IGNORE_RETURN;
+- if (should_suppress_fork (second))
+- {
+- second->flags |= CMD_NO_FORK;
+- second->value.Simple->flags |= CMD_NO_FORK;
+- }
+
+ exec_result = execute_command (second);
+--- 2630,2633 ----