summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-10 19:21:36 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-10 19:21:36 +0000
commita2f14479a151e6d4f31a22d1d6a892ef0716a27c (patch)
tree5c20583c50c8dc86c90db4016b78b09fc5d9bf62
parentDon't install spurious COPYING files. (diff)
downloadgentoo-2-a2f14479a151e6d4f31a22d1d6a892ef0716a27c.tar.gz
gentoo-2-a2f14479a151e6d4f31a22d1d6a892ef0716a27c.tar.bz2
gentoo-2-a2f14479a151e6d4f31a22d1d6a892ef0716a27c.zip
Add new revisions to allow slot 0 and slot 7.0 to be installed at the same time, fixing bug 527670.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/ohai/ChangeLog10
-rw-r--r--dev-ruby/ohai/ohai-6.22.0-r1.ebuild52
-rw-r--r--dev-ruby/ohai/ohai-7.0.4-r1.ebuild (renamed from dev-ruby/ohai/ohai-7.0.4.ebuild)4
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
index cfa5bc33242c..fa4f336fc611 100644
--- a/dev-ruby/ohai/ChangeLog
+++ b/dev-ruby/ohai/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ohai
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.23 2014/11/10 19:09:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.24 2014/11/10 19:21:36 graaff Exp $
+
+*ohai-7.0.4-r1 (10 Nov 2014)
+*ohai-6.22.0-r1 (10 Nov 2014)
+
+ 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ohai-6.22.0-r1.ebuild,
+ -ohai-7.0.4.ebuild, +ohai-7.0.4-r1.ebuild:
+ Add new revisions to allow slot 0 and slot 7.0 to be installed at the same
+ time, fixing bug 527670.
10 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ohai-6.18.0.ebuild:
Cleanup.
diff --git a/dev-ruby/ohai/ohai-6.22.0-r1.ebuild b/dev-ruby/ohai/ohai-6.22.0-r1.ebuild
new file mode 100644
index 000000000000..6ad27a4a8d47
--- /dev/null
+++ b/dev-ruby/ohai/ohai-6.22.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-6.22.0-r1.ebuild,v 1.1 2014/11/10 19:21:36 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/chef/Ohai"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/ipaddress
+ dev-ruby/yajl-ruby
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ dev-ruby/mixlib-shellout
+ >=dev-ruby/systemu-2.5.0"
+
+all_ruby_prepare() {
+ rm Gemfile .rspec || die
+ # Be more lenient to work with versions of systemu that we have in
+ # the tree.
+ sed -i -e 's/~> 2.5.2/>= 2.5.2/' ohai.gemspec || die
+
+ # Remove the Darwin-specific tests that require additional
+ # dependencies.
+ rm -rf spec/unit/plugins/darwin || die
+
+ # Avoid the ruby plugin tests because these always execute the
+ # system ruby, rather than the current ruby.
+ rm -rf spec/unit/plugins/ruby_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}
diff --git a/dev-ruby/ohai/ohai-7.0.4.ebuild b/dev-ruby/ohai/ohai-7.0.4-r1.ebuild
index 55f81f43f64d..46bc11361bee 100644
--- a/dev-ruby/ohai/ohai-7.0.4.ebuild
+++ b/dev-ruby/ohai/ohai-7.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-7.0.4.ebuild,v 1.1 2014/07/22 06:20:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-7.0.4-r1.ebuild,v 1.1 2014/11/10 19:21:36 graaff Exp $
EAPI=5
USE_RUBY="ruby19"
@@ -21,6 +21,8 @@ SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RDEPEND+="!!<dev-ruby/ohai-6.22.0-r1"
+
ruby_add_rdepend "
>=dev-ruby/mime-types-1.16:0
dev-ruby/ipaddress