summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-04 02:19:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-04 02:19:53 +0000
commit9a6b99830f10b6bcc83284fe92a0cb4bc714a5b6 (patch)
treea6ac8c223b5b0e6efd24c955f14b1e275d95eae2
parentadd support to not build with ocmlopt (diff)
downloadgentoo-2-9a6b99830f10b6bcc83284fe92a0cb4bc714a5b6.tar.gz
gentoo-2-9a6b99830f10b6bcc83284fe92a0cb4bc714a5b6.tar.bz2
gentoo-2-9a6b99830f10b6bcc83284fe92a0cb4bc714a5b6.zip
version bump, allow to build without ocamlopt
(Portage version: 2.1.4_rc14)
-rw-r--r--dev-ml/res/ChangeLog9
-rw-r--r--dev-ml/res/files/digest-res-2.2.53
-rw-r--r--dev-ml/res/res-2.2.5.ebuild55
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-ml/res/ChangeLog b/dev-ml/res/ChangeLog
index cb7ce3c45ab4..b059970274e0 100644
--- a/dev-ml/res/ChangeLog
+++ b/dev-ml/res/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/res
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/res/ChangeLog,v 1.4 2007/02/09 07:37:56 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/res/ChangeLog,v 1.5 2008/01/04 02:19:53 aballier Exp $
+
+*res-2.2.5 (04 Jan 2008)
+
+ 04 Jan 2008; Alexis Ballier <aballier@gentoo.org> +res-2.2.5.ebuild:
+ version bump, allow to build without ocamlopt
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-ml/res/files/digest-res-2.2.5 b/dev-ml/res/files/digest-res-2.2.5
new file mode 100644
index 000000000000..685673a7bb50
--- /dev/null
+++ b/dev-ml/res/files/digest-res-2.2.5
@@ -0,0 +1,3 @@
+MD5 6990499f7fa6dbc555c30e1324f66f28 res-2.2.5.tar.bz2 33684
+RMD160 767c73c2e83e7a2f592a03ca5091ce66fb04272c res-2.2.5.tar.bz2 33684
+SHA256 66baf7fad87e0d57ce1f26aebcfa28dbcfabfb398e359541f8c0335122df0ac6 res-2.2.5.tar.bz2 33684
diff --git a/dev-ml/res/res-2.2.5.ebuild b/dev-ml/res/res-2.2.5.ebuild
new file mode 100644
index 000000000000..adff88d0804c
--- /dev/null
+++ b/dev-ml/res/res-2.2.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/res/res-2.2.5.ebuild,v 1.1 2008/01/04 02:19:53 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples +ocamlopt"
+
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+
+ if use doc; then
+ emake htdoc || die "failed to build documentation"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README TODO VERSION Changes
+
+ if use doc; then
+ dohtml lib/doc/res/html/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}