summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-11-05 17:41:41 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-11-05 17:41:41 +0000
commit959dbfec059f5fafe335cd50377484b257ad920a (patch)
tree17d92ad4285bd384066f1812089a71c00f28ccfb
parentclean up (diff)
downloadgentoo-2-959dbfec059f5fafe335cd50377484b257ad920a.tar.gz
gentoo-2-959dbfec059f5fafe335cd50377484b257ad920a.tar.bz2
gentoo-2-959dbfec059f5fafe335cd50377484b257ad920a.zip
clean up
(Portage version: 2.1.4.5)
-rw-r--r--net-analyzer/nload/ChangeLog7
-rw-r--r--net-analyzer/nload/files/nload-0.6.0-prevent-stripping.patch15
-rw-r--r--net-analyzer/nload/files/nload-0.6.0-signedness.patch99
-rw-r--r--net-analyzer/nload/nload-0.6.0-r2.ebuild30
4 files changed, 6 insertions, 145 deletions
diff --git a/net-analyzer/nload/ChangeLog b/net-analyzer/nload/ChangeLog
index 27af4abb7d0d..c6a593377670 100644
--- a/net-analyzer/nload/ChangeLog
+++ b/net-analyzer/nload/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nload
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.28 2008/06/29 14:04:11 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/ChangeLog,v 1.29 2008/11/05 17:41:41 opfer Exp $
+
+ 05 Nov 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/nload-0.6.0-prevent-stripping.patch,
+ -files/nload-0.6.0-signedness.patch, -nload-0.6.0-r2.ebuild:
+ clean up
29 Jun 2008; nixnut <nixnut@gentoo.org> nload-0.7.1.ebuild:
Stable on ppc wrt bug 229995
diff --git a/net-analyzer/nload/files/nload-0.6.0-prevent-stripping.patch b/net-analyzer/nload/files/nload-0.6.0-prevent-stripping.patch
deleted file mode 100644
index a856f8ece058..000000000000
--- a/net-analyzer/nload/files/nload-0.6.0-prevent-stripping.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: nload-0.6.0/configure.in
-===================================================================
---- nload-0.6.0.orig/configure.in
-+++ nload-0.6.0/configure.in
-@@ -76,8 +76,8 @@ fi
- dnl Adds extra arguments to configure script.
- AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug], [do not strip debugging symbols (default no)]),
-- test "$enableval" = "no" && LDFLAGS="$LDFLAGS -s",
-- LDFLAGS="$LDFLAGS -s")
-+ test "$enableval" = "no" && LDFLAGS="$LDFLAGS",
-+ LDFLAGS="$LDFLAGS")
-
- dnl Checks for library functions.
- AC_TYPE_SIGNAL
diff --git a/net-analyzer/nload/files/nload-0.6.0-signedness.patch b/net-analyzer/nload/files/nload-0.6.0-signedness.patch
deleted file mode 100644
index 53d53c1a80e0..000000000000
--- a/net-analyzer/nload/files/nload-0.6.0-signedness.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- nload-0.6.0.orig/src/proc.h
-+++ nload-0.6.0/src/proc.h
-@@ -36,8 +36,8 @@
-
- void readLoad( unsigned long& in, unsigned long& out );
-
-- unsigned long totalIn();
-- unsigned long totalOut();
-+ long long totalIn();
-+ long long totalOut();
-
- int getElapsedTime();
-
-@@ -51,7 +51,7 @@
-
- char m_ip[16];
-
-- unsigned long m_total[2];
-+ long long m_total[2];
-
- };
-
---- nload-0.6.0.orig/src/status.h
-+++ nload-0.6.0/src/status.h
-@@ -52,7 +52,7 @@
- gigabyte = 7
- };
-
-- void update( unsigned long, unsigned long );
-+ void update( unsigned long, long long);
- void print( Window&, int, int, status_format traff_format, status_format data_format );
- void resetTrafficData();
-
---- nload-0.6.0.orig/src/proc.cpp
-+++ nload-0.6.0/src/proc.cpp
-@@ -126,7 +126,7 @@
-
- void Proc::readLoad( unsigned long& in, unsigned long& out )
- {
-- unsigned long total_new[2] = { 0, 0 };
-+ long long total_new[2] = { 0, 0 };
- int curr_time = 0;
- struct timeval time;
-
-@@ -181,7 +181,7 @@
-
- if( ! strcmp( m_dev, dev ) )
- {
-- sscanf( tmp, "%lu %*u %*u %*u %*u %*u %*u %*u %lu", &total_new[0], &total_new[1] );
-+ sscanf( tmp, "%llu %*u %*u %*u %*u %*u %*u %*u %llu", &total_new[0], &total_new[1] );
-
- if( total_new[0] > m_total[0] )
- in = total_new[0] - m_total[0];
-@@ -198,7 +198,7 @@
- }
- } while( 0 );
-
-- fclose(fd);
-+ if (fd != NULL) fclose(fd);
-
- #endif
- // === End Linux specific network data reading code ===
-@@ -513,12 +513,12 @@
- return m_elapsed_time;
- }
-
--unsigned long Proc::totalIn()
-+long long Proc::totalIn()
- {
- return m_total[0];
- }
-
--unsigned long Proc::totalOut()
-+long long Proc::totalOut()
- {
- return m_total[1];
- }
---- nload-0.6.0.orig/src/status.cpp
-+++ nload-0.6.0/src/status.cpp
-@@ -30,7 +30,7 @@
- }
-
- //new traffic measurement has been made => update statistics
--void Status::update( unsigned long new_value, unsigned long new_total )
-+void Status::update( unsigned long new_value, long long new_total )
- {
-
- m_cur = new_value;
-@@ -44,7 +44,9 @@
- *the /proc/net/dev file
- *(the total bytes value reaches 4GB and then switches to 0)
- */
-- if( new_total < ( m_total % UINT_MAX ) )
-+ if (new_total >= UINT_MAX )
-+ m_total = new_total;
-+ else if ( new_total < ( m_total % UINT_MAX ) )
- m_total = ( ( m_total / UINT_MAX ) + 1 ) * UINT_MAX + new_total;
- else
- m_total = ( m_total / UINT_MAX ) * UINT_MAX + new_total;
diff --git a/net-analyzer/nload/nload-0.6.0-r2.ebuild b/net-analyzer/nload/nload-0.6.0-r2.ebuild
deleted file mode 100644
index 4bfd7f1aff9d..000000000000
--- a/net-analyzer/nload/nload-0.6.0-r2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nload/nload-0.6.0-r2.ebuild,v 1.3 2007/09/23 18:37:44 philantrop Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
-SRC_URI="mirror://sourceforge/nload/${P}.tar.gz"
-HOMEPAGE="http://roland-riegel.de/nload/index_en.html"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5.2"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-prevent-stripping.patch
- epatch "${FILESDIR}"/${P}-signedness.patch
- eautoreconf
-}
-
-src_install () {
- #make DESTDIR=${D} install
- einstall || die
- dodoc README INSTALL ChangeLog AUTHORS
-}