summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-08 21:16:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-08 21:16:44 +0000
commit94f21dfdd958832ab714411250d8b42ae5cdda9c (patch)
tree4b1c161b2f30f65a29a84cfa7f1a83d9becf06b4
parentBump to releases 7.37 and 8.0.0_beta10. (diff)
downloadgentoo-2-94f21dfdd958832ab714411250d8b42ae5cdda9c.tar.gz
gentoo-2-94f21dfdd958832ab714411250d8b42ae5cdda9c.tar.bz2
gentoo-2-94f21dfdd958832ab714411250d8b42ae5cdda9c.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-strategy/megaglest-data/ChangeLog10
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/games-strategy/megaglest-data/ChangeLog b/games-strategy/megaglest-data/ChangeLog
index fceb7eaa04fb..3abb5cff75f8 100644
--- a/games-strategy/megaglest-data/ChangeLog
+++ b/games-strategy/megaglest-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/megaglest-data
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.15 2014/12/08 02:20:53 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/ChangeLog,v 1.16 2015/05/08 21:16:44 mr_bones_ Exp $
+
+*megaglest-data-3.11.1 (08 May 2015)
+
+ 08 May 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +megaglest-data-3.11.1.ebuild:
+ version bump
08 Dec 2014; Patrick Lauer <patrick@gentoo.org>
-megaglest-data-3.6.0.3.ebuild, -megaglest-data-3.7.0.ebuild,
diff --git a/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild
new file mode 100644
index 000000000000..de19da9724e8
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/megaglest-data/megaglest-data-3.11.1.ebuild,v 1.1 2015/05/08 21:16:44 mr_bones_ Exp $
+
+EAPI=5
+inherit cmake-utils games
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEGAGLEST_BIN_INSTALL_PATH="${GAMES_BINDIR}"
+ -DMEGAGLEST_DATA_INSTALL_PATH="${GAMES_DATADIR}/${MY_PN}"
+ -DMEGAGLEST_ICON_INSTALL_PATH="/usr/share/pixmaps"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS="docs/glest_factions/"
+ cmake-utils_src_install
+ prepgamesdirs
+}