summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-12 23:36:44 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-12 23:36:44 +0000
commit8dd53068422a93bd7c023b223ccc9416644af9ed (patch)
tree09566365113f31ab0218449a9163f9adf07ca8a6
parentFix missing distfiles digests. Thanks to Brian Harring for reporting. (diff)
downloadgentoo-2-8dd53068422a93bd7c023b223ccc9416644af9ed.tar.gz
gentoo-2-8dd53068422a93bd7c023b223ccc9416644af9ed.tar.bz2
gentoo-2-8dd53068422a93bd7c023b223ccc9416644af9ed.zip
Add djvu support, fix emake -j1 bug 147998 for phreak
(Portage version: 2.1.2_rc3-r4)
-rw-r--r--app-text/ghostscript-gpl/ChangeLog6
-rw-r--r--app-text/ghostscript-gpl/files/digest-ghostscript-gpl-8.543
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild47
3 files changed, 41 insertions, 15 deletions
diff --git a/app-text/ghostscript-gpl/ChangeLog b/app-text/ghostscript-gpl/ChangeLog
index 6301dd70667e..5f3cb7568c4d 100644
--- a/app-text/ghostscript-gpl/ChangeLog
+++ b/app-text/ghostscript-gpl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript-gpl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ChangeLog,v 1.7 2006/11/04 00:31:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ChangeLog,v 1.8 2006/12/12 23:36:44 genstef Exp $
+
+ 12 Dec 2006; Stefan Schweizer <genstef@gentoo.org>
+ ghostscript-gpl-8.54.ebuild:
+ Add djvu support, fix emake -j1 bug 147998 for phreak
04 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
ghostscript-gpl-8.54.ebuild:
diff --git a/app-text/ghostscript-gpl/files/digest-ghostscript-gpl-8.54 b/app-text/ghostscript-gpl/files/digest-ghostscript-gpl-8.54
index a3388250d133..f7be16b158b0 100644
--- a/app-text/ghostscript-gpl/files/digest-ghostscript-gpl-8.54
+++ b/app-text/ghostscript-gpl/files/digest-ghostscript-gpl-8.54
@@ -13,3 +13,6 @@ SHA256 3905677ab494a1b82ee2a6cc78975a5fdc08d81a65c12af35746bb3d2889b3e2 gdevhl12
MD5 5d0ad0da8297fe459a788200f0eaeeba ghostscript-8.54-gpl.tar.bz2 12365361
RMD160 f61f6da568ffe440a466cd0d7b5871a3d87d1116 ghostscript-8.54-gpl.tar.bz2 12365361
SHA256 64f43553223390a3e519efed2b3dfee8a4c79df5a373a0e96861483565957e1b ghostscript-8.54-gpl.tar.bz2 12365361
+MD5 46bce036ad0b9b284f4c8f3530f7c684 gsdjvu-1.1.tar.gz 214364
+RMD160 aa1ff4a80b02b16e43bf8e14719613f98bdf13c6 gsdjvu-1.1.tar.gz 214364
+SHA256 39f32b9946a65cbe8d5b7c2882ef0e82d5858e78e04b568bb525d2c4e2d6ce78 gsdjvu-1.1.tar.gz 214364
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
index bbb3d6d4632a..da5f893da842 100644
--- a/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
@@ -1,18 +1,21 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild,v 1.7 2006/11/04 00:31:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild,v 1.8 2006/12/12 23:36:44 genstef Exp $
WANT_AUTOMAKE=1.6
+
inherit autotools elisp-common eutils versionator flag-o-matic
DESCRIPTION="GPL Ghostscript - the most current Ghostscript, AFPL, relicensed"
HOMEPAGE="http://www.cs.wisc.edu/~ghost/"
+GSDJVU_PV=1.1
CUPS_PV=1.1.23
MY_P=ghostscript-${PV}-gpl
PVM=$(get_version_component_range 1-2)
SRC_URI="cjk? ( ftp://ftp.gyve.org/pub/gs-cjk/adobe-cmaps-200406.tar.gz
ftp://ftp.gyve.org/pub/gs-cjk/acro5-cmaps-2001.tar.gz )
+ djvu? ( mirror://sourceforge/djvu/gsdjvu-${GSDJVU_PV}.tar.gz )
cups? ( mirror://gentoo/cups-${CUPS_PV}-source.tar.bz2 )
mirror://sourceforge/ghostscript/${MY_P}.tar.bz2
mirror://gentoo/gdevhl12.c.gz"
@@ -20,7 +23,7 @@ SRC_URI="cjk? ( ftp://ftp.gyve.org/pub/gs-cjk/adobe-cmaps-200406.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="X cups cjk emacs gtk jpeg2k"
+IUSE="X cups cjk emacs gtk djvu jpeg2k"
DEP="virtual/libc
>=media-libs/jpeg-6b
@@ -28,6 +31,7 @@ DEP="virtual/libc
>=sys-libs/zlib-1.1.4
>=media-libs/tiff-3.7
X? ( x11-libs/libXt x11-libs/libXext )
+ djvu? ( app-text/djvu )
gtk? ( >=x11-libs/gtk+-2.0 )
cups? ( >=net-print/cups-1.1.20 )
jpeg2k? ( media-libs/jasper )
@@ -41,7 +45,7 @@ RDEPEND="${DEP}
media-fonts/gnu-gs-fonts-std"
DEPEND="${DEP}
- gtk? ( dev-util/pkgconfig )"
+ dev-util/pkgconfig"
S=${WORKDIR}/${MY_P}
@@ -75,6 +79,17 @@ src_unpack() {
sed -i -e 's:EXTRALIBS=.*:\0 -lcups -lcupsimage:' src/Makefile.in || die "sed failed"
fi
cd ${S}
+
+ if use djvu; then
+ unpack gsdjvu-${GSDJVU_PV}.tar.gz
+ cp gsdjvu-${GSDJVU_PV}/gsdjvu ${S}
+ cp gsdjvu-${GSDJVU_PV}/gdevdjvu.c ${S}/src
+ cp gsdjvu-${GSDJVU_PV}/ps2utf8.ps ${S}/lib
+ cp ${S}/src/contrib.mak ${S}/src/contrib.mak.gsdjvu
+ grep -q djvusep ${S}/src/contrib.mak || \
+ cat gsdjvu-${GSDJVU_PV}/gsdjvu.mak >> ${S}/src/contrib.mak
+ fi
+
epatch ${FILESDIR}/ghostscript-afpl-8.54-cups-lib.patch
epatch ${FILESDIR}/ghostscript-afpl-8.54-big-cmap-post.patch
@@ -106,24 +121,26 @@ src_unpack() {
# search path fix
sed -i -e "s:\$\(gsdatadir\)/lib:/usr/share/ghostscript/${PVM}/$(get_libdir):" \
- src/Makefile.in || die "sed failed"
- sed -i -e 's:$(gsdir)/fonts:/usr/share/fonts/default/ghostscript/:' \
- src/Makefile.in || die "sed failed"
- sed -i -e "s:exdir=.*:exdir=/usr/share/doc/${PF}/examples:" \
- src/Makefile.in || die "sed failed"
- sed -i -e "s:docdir=.*:docdir=/usr/share/doc/${PF}/html:" \
+ -e 's:$(gsdir)/fonts:/usr/share/fonts/default/ghostscript/:' \
+ -e "s:exdir=.*:exdir=/usr/share/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=/usr/share/doc/${PF}/html:" \
-e "s:GS_DOCDIR=.*:GS_DOCDIR=/usr/share/doc/${PF}/html:" \
src/Makefile.in src/*.mak || die "sed failed"
}
src_compile() {
- econf \
- $(use_with X x) \
+ econf $(use_with X x) \
$(use_with jpeg2k jasper) \
--with-ijs \
- --with-jbig2dec \
- || die "econf failed"
- emake STDDIRS || die "emake failed"
+ --with-jbig2dec || die "econf failed"
+
+ if use djvu; then
+ sed -i -e 's!$(DD)bbox.dev!& $(DD)djvumask.dev $(DD)djvusep.dev!g' Makefile
+ sed -i -e 's:(/\(Resource/[a-zA-Z/]*\)):(\1) findlibfile {pop} {pop &}
+ ifelse:' lib/gs_res.ps
+ fi
+
+ emake -j1 so all || die "emake failed"
cd ijs
econf || die "ijs econf failed"
@@ -133,6 +150,8 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install soinstall || die "emake install failed"
+ use djvu && dobin gsdjvu
+
rm -fr ${D}/usr/share/doc/${PF}/html/{README,PUBLIC}
dodoc doc/README
use emacs && elisp-site-file-install doc/gsdoc.el