summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-02-28 18:16:49 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-02-28 18:16:49 +0000
commit8b68012fd1cd3b11deb3a958f31dde2454f9ab33 (patch)
tree87cb195e6db5f3c21790e4ca5a5371cac226b1a0
parentRemove unused files in FILESDIR. (diff)
downloadgentoo-2-8b68012fd1cd3b11deb3a958f31dde2454f9ab33.tar.gz
gentoo-2-8b68012fd1cd3b11deb3a958f31dde2454f9ab33.tar.bz2
gentoo-2-8b68012fd1cd3b11deb3a958f31dde2454f9ab33.zip
Added nagios plugin to check the status of bonded network interfaces via Nagios.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
-rw-r--r--net-analyzer/nagios-check_linux_bonding/ChangeLog10
-rw-r--r--net-analyzer/nagios-check_linux_bonding/metadata.xml9
-rw-r--r--net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_linux_bonding/ChangeLog b/net-analyzer/nagios-check_linux_bonding/ChangeLog
new file mode 100644
index 000000000000..b4d77a4866c3
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/nagios-check_linux_bonding
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_linux_bonding/ChangeLog,v 1.1 2014/02/28 18:16:49 ercpe Exp $
+
+*nagios-check_linux_bonding-1.3.2 (28 Feb 2014)
+
+ 28 Feb 2014; Johann Schmitz <ercpe@gentoo.org> +metadata.xml,
+ +nagios-check_linux_bonding-1.3.2.ebuild:
+ Added nagios plugin to check the status of bonded network interfaces via
+ Nagios.
diff --git a/net-analyzer/nagios-check_linux_bonding/metadata.xml b/net-analyzer/nagios-check_linux_bonding/metadata.xml
new file mode 100644
index 000000000000..4128863055b4
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild
new file mode 100644
index 000000000000..053f36356f29
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.3.2.ebuild,v 1.1 2014/02/28 18:16:49 ercpe Exp $
+
+EAPI=5
+
+inherit multilib
+
+MY_P=${P/nagios-/}
+
+DESCRIPTION="Nagios plugin to monitor bonding status of network interfaces"
+HOMEPAGE="http://folk.uio.no/trondham/software/check_linux_bonding.html"
+SRC_URI="http://folk.uio.no/trondham/software/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+ dodir "${nagiosplugindir}"
+ exeinto ${nagiosplugindir}
+ doexe check_linux_bonding
+
+ dodoc CHANGES
+ doman man/check_linux_bonding.8
+}