summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-08 16:54:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-08 16:54:19 +0000
commit60390787629a73dba974a6bb251895162cee09ea (patch)
tree744115c51d5c209f18152d1f061ead18e2ef14e3
parentVersion bump to 1.1.2 . Remove old ebuild (diff)
downloadgentoo-2-60390787629a73dba974a6bb251895162cee09ea.tar.gz
gentoo-2-60390787629a73dba974a6bb251895162cee09ea.tar.bz2
gentoo-2-60390787629a73dba974a6bb251895162cee09ea.zip
Skip test failing with C locale (bug #287439).
(Portage version: 14804-svn/cvs/Linux x86_64)
-rw-r--r--dev-python/setuptools/ChangeLog7
-rw-r--r--dev-python/setuptools/files/distribute-0.6.8-C_locale_tests.patch11
-rw-r--r--dev-python/setuptools/setuptools-0.6.6.ebuild11
-rw-r--r--dev-python/setuptools/setuptools-0.6.8.ebuild9
4 files changed, 32 insertions, 6 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 874ce18ac996..d3bc569d4ef9 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.82 2009/11/08 16:41:39 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.83 2009/11/08 16:54:19 arfrever Exp $
+
+ 08 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ setuptools-0.6.6.ebuild, setuptools-0.6.8.ebuild,
+ +files/distribute-0.6.8-C_locale_tests.patch:
+ Skip test failing with C locale (bug #287439).
08 Nov 2009; Tobias Klausmann <klausman@gentoo.org>
setuptools-0.6.6.ebuild:
diff --git a/dev-python/setuptools/files/distribute-0.6.8-C_locale_tests.patch b/dev-python/setuptools/files/distribute-0.6.8-C_locale_tests.patch
new file mode 100644
index 000000000000..2580e355486d
--- /dev/null
+++ b/dev-python/setuptools/files/distribute-0.6.8-C_locale_tests.patch
@@ -0,0 +1,11 @@
+--- setuptools/tests/test_resources.py
++++ setuptools/tests/test_resources.py
+@@ -536,6 +536,8 @@
+ '#!%s -x\n' % self.non_ascii_exe)
+
+ def test_get_script_header_jython_workaround(self):
++ if os.environ.get("LC_ALL") == "C":
++ return
+ platform = sys.platform
+ sys.platform = 'java1.5.0_13'
+ stdout = sys.stdout
diff --git a/dev-python/setuptools/setuptools-0.6.6.ebuild b/dev-python/setuptools/setuptools-0.6.6.ebuild
index 72c7da7d9d2a..5d6e34f642e0 100644
--- a/dev-python/setuptools/setuptools-0.6.6.ebuild
+++ b/dev-python/setuptools/setuptools-0.6.6.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.6.ebuild,v 1.5 2009/11/08 16:41:39 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.6.ebuild,v 1.6 2009/11/08 16:54:19 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
-DESCRIPTION="A collection of enhancements to the Python distutils including easy install"
+MY_PN="distribute"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
HOMEPAGE="http://pypi.python.org/pypi/distribute"
-SRC_URI="http://pypi.python.org/packages/source/d/distribute/distribute-${PV}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="PSF-2.2"
SLOT="0"
@@ -28,6 +31,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+ epatch "${FILESDIR}/${MY_PN}-0.6.8-C_locale_tests.patch"
+
# Remove tests that access the network (bugs #198312, #191117)
rm setuptools/tests/test_packageindex.py
diff --git a/dev-python/setuptools/setuptools-0.6.8.ebuild b/dev-python/setuptools/setuptools-0.6.8.ebuild
index 0757285a26f2..04d3307fe884 100644
--- a/dev-python/setuptools/setuptools-0.6.8.ebuild
+++ b/dev-python/setuptools/setuptools-0.6.8.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.8.ebuild,v 1.3 2009/11/06 17:47:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.8.ebuild,v 1.4 2009/11/08 16:54:19 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
+MY_PN="distribute"
+MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
HOMEPAGE="http://pypi.python.org/pypi/distribute"
-SRC_URI="http://pypi.python.org/packages/source/d/distribute/distribute-${PV}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="PSF-2.2"
SLOT="0"
@@ -28,6 +31,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+ epatch "${FILESDIR}/${MY_P}-C_locale_tests.patch"
+
# Remove tests that access the network (bugs #198312, #191117)
rm setuptools/tests/test_packageindex.py