summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 02:45:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 02:45:21 +0000
commit573e890f5bb24044404edfc5f39473f66acca044 (patch)
treee2245667ebea4b048fe30e69cfba83d2f34e159c
parentAllow installation alongside mozilla-firefox-bin now that they can co-exist a... (diff)
downloadgentoo-2-573e890f5bb24044404edfc5f39473f66acca044.tar.gz
gentoo-2-573e890f5bb24044404edfc5f39473f66acca044.tar.bz2
gentoo-2-573e890f5bb24044404edfc5f39473f66acca044.zip
arm KEYWORDS
-rw-r--r--app-editors/hexcurse/hexcurse-1.55.ebuild4
-rw-r--r--app-editors/hexedit/hexedit-1.2.9.ebuild28
-rw-r--r--media-libs/jpeg/jpeg-6b-r3.ebuild21
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild18
4 files changed, 28 insertions, 43 deletions
diff --git a/app-editors/hexcurse/hexcurse-1.55.ebuild b/app-editors/hexcurse/hexcurse-1.55.ebuild
index 0a348978058d..bcb19fef930c 100644
--- a/app-editors/hexcurse/hexcurse-1.55.ebuild
+++ b/app-editors/hexcurse/hexcurse-1.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.3 2004/04/19 06:28:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.4 2004/05/28 02:41:11 vapier Exp $
DESCRIPTION="ncurses based hex editor"
HOMEPAGE="http://www.jewfish.net/software/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.jewfish.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc hppa amd64"
+KEYWORDS="x86 ppc sparc arm hppa amd64"
IUSE=""
DEPEND=">=sys-libs/ncurses-5.2"
diff --git a/app-editors/hexedit/hexedit-1.2.9.ebuild b/app-editors/hexedit/hexedit-1.2.9.ebuild
index 4c0601e9ce17..c2dad23bbee4 100644
--- a/app-editors/hexedit/hexedit-1.2.9.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.9.ebuild
@@ -1,30 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.9.ebuild,v 1.1 2004/04/13 16:24:06 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexedit/hexedit-1.2.9.ebuild,v 1.2 2004/05/28 02:41:17 vapier Exp $
-S="${WORKDIR}/hexedit"
-DESCRIPTION="View and edit files in hex or ASCII."
-SRC_URI="http://merd.net/pixel/${P}.src.tgz"
+DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://www.chez.com/prigaux/hexedit.html"
+SRC_URI="http://merd.net/pixel/${P}.src.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha arm ~amd64"
+IUSE=""
DEPEND="virtual/glibc
sys-libs/ncurses"
RDEPEND=""
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
-LICENSE="GPL-1"
-
-src_compile() {
- cd "${S}"
- ./configure --host="${CHOST}" --prefix=/usr --mandir=/usr/share/man \
- || die "./configure failed"
-
- emake || die
-}
+S="${WORKDIR}/hexedit"
src_install () {
- dobin hexedit
+ dobin hexedit || die
doman hexedit.1
- dodoc COPYING Changes TODO
+ dodoc Changes TODO
}
diff --git a/media-libs/jpeg/jpeg-6b-r3.ebuild b/media-libs/jpeg/jpeg-6b-r3.ebuild
index b2499d325276..d127497eef33 100644
--- a/media-libs/jpeg/jpeg-6b-r3.ebuild
+++ b/media-libs/jpeg/jpeg-6b-r3.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r3.ebuild,v 1.23 2004/05/07 19:21:03 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r3.ebuild,v 1.24 2004/05/28 02:45:21 vapier Exp $
inherit gnuconfig flag-o-matic
MY_P=${PN}src.v${PV}
DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
-SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${MY_P}.tar.gz"
HOMEPAGE="http://www.ijg.org/"
+SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 mips ppc64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+IUSE=""
RDEPEND="virtual/glibc"
-
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
@@ -24,18 +24,11 @@ src_unpack() {
# allow /etc/make.conf's HOST setting to apply
cd ${S}
sed -i 's/ltconfig.*/& $CHOST/' configure
- use alpha && gnuconfig_update
- use hppa && gnuconfig_update
- use amd64 && gnuconfig_update
- use ia64 && gnuconfig_update
- use ppc64 && gnuconfig_update
- use s390 && gnuconfig_update
+ gnuconfig_update
}
src_compile() {
- replace-flags k6-3 i586
- replace-flags k6-2 i586
- replace-flags k6 i586
+ replace-cpu-flags i586 k6 k6-2 k6-3
econf --enable-shared --enable-static || die "econf failed"
diff --git a/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild
index b47ccb877ad7..3951e72c3126 100644
--- a/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild,v 1.1 2004/05/14 19:12:07 avenj Exp $
-
-DESCRIPTION="Small forwarding DNS server for local networks"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.8-r1.ebuild,v 1.2 2004/05/28 02:43:58 vapier Exp $
MY_P="${P/_/}"
MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server for local networks"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
-SLOT="0"
-
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~ia64 ~amd64 ~mips s390"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips arm ~amd64 ~ia64 s390"
+IUSE=""
DEPEND="virtual/glibc
>=sys-apps/sed-4"
-
S="${WORKDIR}/${PN}-${MY_PV}"
src_unpack() {
@@ -32,9 +30,9 @@ src_compile() {
}
src_install() {
- dosbin src/dnsmasq
+ dosbin src/dnsmasq || die
doman dnsmasq.8
- dodoc CHANGELOG COPYING FAQ
+ dodoc CHANGELOG FAQ
dohtml *.html
exeinto /etc/init.d