summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2013-03-06 03:29:45 +0000
committerJeff Horelick <jdhore@gentoo.org>2013-03-06 03:29:45 +0000
commit56fe6e51ef291f194c2579cea586f4914cb10b9a (patch)
treee900d27a5984c5549d45c1a329bca16d0146129f
parenttar.gz is half the size, switch to using that instead of zip (diff)
downloadgentoo-2-56fe6e51ef291f194c2579cea586f4914cb10b9a.tar.gz
gentoo-2-56fe6e51ef291f194c2579cea586f4914cb10b9a.tar.bz2
gentoo-2-56fe6e51ef291f194c2579cea586f4914cb10b9a.zip
Version bump and remove old
(Portage version: 2.2.0_alpha166/cvs/Linux i686, signed Manifest commit with key 23E9E900)
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog9
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.14.ebuild (renamed from sys-apps/the_silver_searcher/the_silver_searcher-0.12.ebuild)14
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.8.ebuild25
3 files changed, 18 insertions, 30 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index 86815ca90074..f568c6a5d09b 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.23 2013/02/09 20:02:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.24 2013/03/06 03:29:45 jdhore Exp $
+
+*the_silver_searcher-0.14 (06 Mar 2013)
+
+ 06 Mar 2013; Jeff Horelick <jdhore@gentoo.org>
+ +the_silver_searcher-0.14.ebuild, -the_silver_searcher-0.12.ebuild,
+ -the_silver_searcher-0.8.ebuild:
+ Version bump and remove old
09 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
the_silver_searcher-0.13.1.ebuild:
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.12.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.14.ebuild
index be26537140a4..534c225f41db 100644
--- a/sys-apps/the_silver_searcher/the_silver_searcher-0.12.ebuild
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.14.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.12.ebuild,v 1.1 2012/10/20 14:33:43 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.14.ebuild,v 1.1 2013/03/06 03:29:45 jdhore Exp $
EAPI=5
-inherit autotools
+inherit autotools bash-completion-r1
DESCRIPTION="A code-searching tool similar to ack, but faster"
HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
-SRC_URI="mirror://github/ggreer/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,5 +21,11 @@ DEPEND="${RDEPEND}
DOCS="README.md"
src_prepare() {
+ sed -i -e 's/ag\.bashcomp\.sh//' Makefile.am || die
eautoreconf
}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.8.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.8.ebuild
deleted file mode 100644
index 02b0dbb0acb4..000000000000
--- a/sys-apps/the_silver_searcher/the_silver_searcher-0.8.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.8.ebuild,v 1.3 2012/10/17 03:32:25 phajdan.jr Exp $
-
-EAPI=4
-inherit autotools
-
-DESCRIPTION="A code-searching tool similar to ack, but faster"
-HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
-SRC_URI="mirror://github/ggreer/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-libs/libpcre"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="README.md"
-
-src_prepare() {
- eautoreconf
-}