summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-08 23:25:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-08 23:25:18 +0000
commit4a5d4f1aa3fbf004cb05e7f4761daea9eb4d3a7e (patch)
tree2bec55d55cbc7c91baaaa61034d5e5c7f03fe167
parentBump sys-cluster/torque-2.3.6. Fix repoman warnings. (diff)
downloadgentoo-2-4a5d4f1aa3fbf004cb05e7f4761daea9eb4d3a7e.tar.gz
gentoo-2-4a5d4f1aa3fbf004cb05e7f4761daea9eb4d3a7e.tar.bz2
gentoo-2-4a5d4f1aa3fbf004cb05e7f4761daea9eb4d3a7e.zip
Readding 1.3.0. Oopsie...
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64, RepoMan options: --force)
-rw-r--r--dev-python/twisted/ChangeLog5
-rw-r--r--dev-python/twisted/twisted-1.3.0.ebuild36
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index e3cffaf20a15..11ae93fad737 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.101 2009/01/08 23:11:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.102 2009/01/08 23:25:18 patrick Exp $
+
+ 08 Jan 2009; Patrick Lauer <patrick@gentoo.org> +twisted-1.3.0.ebuild:
+ Readding 1.3.0. Ooopsie ...
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -twisted-1.2.0.ebuild,
-twisted-1.3.0.ebuild, -twisted-2.0.1.ebuild, -twisted-2.1.0.ebuild,
diff --git a/dev-python/twisted/twisted-1.3.0.ebuild b/dev-python/twisted/twisted-1.3.0.ebuild
new file mode 100644
index 000000000000..1fdd24b42029
--- /dev/null
+++ b/dev-python/twisted/twisted-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.3.0.ebuild,v 1.14 2009/01/08 23:25:18 patrick Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/alpha}"
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ia64 ~ppc ~sparc ~x86"
+IUSE="gtk doc"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/pycrypto-1.9_alpha6
+ dev-python/pyserial
+ dev-python/pyopenssl
+ gtk? ( >=dev-python/pygtk-1.99 )
+ doc? ( =dev-python/twisted-docs-${PV} )"
+
+S=${WORKDIR}/Twisted-${MY_PV}
+
+src_install() {
+ distutils_src_install
+
+ # use gtk2 if they so wish
+ if use gtk; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i '${D}/usr/bin/manhole'
+ fi
+}