summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-04-19 21:41:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-04-19 21:41:38 +0000
commit44b78ff1bee9f9ce48ac4dea8841980a0f97e67f (patch)
treecac04c5104509134de326daab4ad01e617b1e11c
parentUse python eclass to force python-2, bug 348885 (diff)
downloadgentoo-2-44b78ff1bee9f9ce48ac4dea8841980a0f97e67f.tar.gz
gentoo-2-44b78ff1bee9f9ce48ac4dea8841980a0f97e67f.tar.bz2
gentoo-2-44b78ff1bee9f9ce48ac4dea8841980a0f97e67f.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
-rw-r--r--dev-cpp/libgdamm/ChangeLog7
-rw-r--r--dev-cpp/libgdamm/libgdamm-4.1.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-cpp/libgdamm/ChangeLog b/dev-cpp/libgdamm/ChangeLog
index e11f434d01bb..a351f46c27d4 100644
--- a/dev-cpp/libgdamm/ChangeLog
+++ b/dev-cpp/libgdamm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libgdamm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/ChangeLog,v 1.17 2011/03/31 13:51:29 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/ChangeLog,v 1.18 2011/04/19 21:41:38 eva Exp $
+
+*libgdamm-4.1.2 (19 Apr 2011)
+
+ 19 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> +libgdamm-4.1.2.ebuild:
+ Version bump.
31 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libgdamm-4.1.1.ebuild:
Fix USE=doc build with newer glibmm
diff --git a/dev-cpp/libgdamm/libgdamm-4.1.2.ebuild b/dev-cpp/libgdamm/libgdamm-4.1.2.ebuild
new file mode 100644
index 000000000000..eb58a63e73e4
--- /dev/null
+++ b/dev-cpp/libgdamm/libgdamm-4.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/libgdamm-4.1.2.ebuild,v 1.1 2011/04/19 21:41:38 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit autotools gnome2
+
+DESCRIPTION="C++ bindings for libgda"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="berkdb doc"
+
+RDEPEND=">=dev-cpp/glibmm-2.27.93:2[doc?]
+ >=gnome-extra/libgda-4.1.7:4[berkdb=]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-cpp/mm-common-0.7.2
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF} $(use_enable doc documentation)"
+}
+
+src_prepare() {
+ if use doc; then
+ mm-common-prepare --copy --force
+ eautoreconf
+ fi
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ #use doc && dohtml -r docs/reference/html/*
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}