summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-29 07:55:48 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-29 07:55:48 +0000
commit4229b1dca8348305c3f75947ae7329ac898b42b2 (patch)
treef4dc2a55fbb640a66d614d802c74f85a44e3dd72
parentFixed slot deps (diff)
downloadgentoo-2-4229b1dca8348305c3f75947ae7329ac898b42b2.tar.gz
gentoo-2-4229b1dca8348305c3f75947ae7329ac898b42b2.tar.bz2
gentoo-2-4229b1dca8348305c3f75947ae7329ac898b42b2.zip
Update to EAPI 2 and use slot deps for gtk+ and glib.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
-rw-r--r--media-sound/terminatorx/ChangeLog7
-rw-r--r--media-sound/terminatorx/terminatorx-3.82.ebuild23
2 files changed, 16 insertions, 14 deletions
diff --git a/media-sound/terminatorx/ChangeLog b/media-sound/terminatorx/ChangeLog
index 479283e114d2..91f2bd3afddc 100644
--- a/media-sound/terminatorx/ChangeLog
+++ b/media-sound/terminatorx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/terminatorx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/ChangeLog,v 1.30 2010/10/24 16:39:59 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/ChangeLog,v 1.31 2011/03/29 07:55:48 radhermit Exp $
+
+ 29 Mar 2011; Tim Harder <radhermit@gentoo.org> terminatorx-3.82.ebuild:
+ Update to EAPI 2 and use slot deps for gtk+ and glib.
24 Oct 2010; Raúl Porcel <armin76@gentoo.org> terminatorx-3.82.ebuild:
Drop sparc keywords
diff --git a/media-sound/terminatorx/terminatorx-3.82.ebuild b/media-sound/terminatorx/terminatorx-3.82.ebuild
index 749bc704a032..76046d47ce4a 100644
--- a/media-sound/terminatorx/terminatorx-3.82.ebuild
+++ b/media-sound/terminatorx/terminatorx-3.82.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.82.ebuild,v 1.16 2010/10/24 16:39:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.82.ebuild,v 1.17 2011/03/29 07:55:48 radhermit Exp $
+
+EAPI=2
inherit gnome2 eutils
MY_P=${P/terminatorx/terminatorX}
-S=${WORKDIR}/${MY_P}
DESCRIPTION='realtime audio synthesizer that allows you to "scratch" on digitally sampled audio data'
HOMEPAGE="http://www.terminatorx.org/"
SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.gz"
@@ -20,8 +21,8 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
vorbis? ( media-libs/libvorbis )
sox? ( media-sound/sox
media-sound/mpg123 )
- >=x11-libs/gtk+-2.2
- >=dev-libs/glib-2.2
+ >=x11-libs/gtk+-2.2:2
+ >=dev-libs/glib-2.2:2
x11-libs/libXi
x11-libs/libXxf86dga
dev-libs/libxml2
@@ -36,22 +37,20 @@ DEPEND="${RDEPEND}
x11-proto/inputproto
x11-proto/xf86dgaproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
# we need the omf fix, or else we get access violation
# errors related to sandbox
gnome2_omf_fix "${S}/doc/terminatorX-manual/C/Makefile.in"
}
-src_compile() {
+src_configure() {
econf \
$(use_enable alsa) \
$(use_enable mad) \
$(use_enable vorbis) \
- $(use_enable sox) \
- || die "econf failed"
- emake || die "emake failed."
+ $(use_enable sox)
}
src_install() {