summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-01-20 23:38:16 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-01-20 23:38:16 +0000
commit3a3b26ca7c493d414416061c81928052fb1bb79f (patch)
treedf61f1de2e4074ed6d7c16abef05b4a88e73359f
parentAllow checking .torrent files by pulling in net-p2p/bittorrent or net-p2p/bit... (diff)
downloadgentoo-2-3a3b26ca7c493d414416061c81928052fb1bb79f.tar.gz
gentoo-2-3a3b26ca7c493d414416061c81928052fb1bb79f.tar.bz2
gentoo-2-3a3b26ca7c493d414416061c81928052fb1bb79f.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
-rw-r--r--dev-python/apiextractor/ChangeLog7
-rw-r--r--dev-python/apiextractor/apiextractor-0.3.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/apiextractor/ChangeLog b/dev-python/apiextractor/ChangeLog
index 94755931220c..90b173a6bc74 100644
--- a/dev-python/apiextractor/ChangeLog
+++ b/dev-python/apiextractor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/apiextractor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.3 2010/01/06 19:50:54 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/ChangeLog,v 1.4 2010/01/20 23:38:16 ayoy Exp $
+
+*apiextractor-0.3.3 (20 Jan 2010)
+
+ 20 Jan 2010; Dominik Kapusta <ayoy@gentoo.org> +apiextractor-0.3.3.ebuild:
+ Version bump
06 Jan 2010; Dominik Kapusta <ayoy@gentoo.org> apiextractor-0.3.2.ebuild:
Restore disabled test and use Xemake in src_test() (bug #299766)
diff --git a/dev-python/apiextractor/apiextractor-0.3.3.ebuild b/dev-python/apiextractor/apiextractor-0.3.3.ebuild
new file mode 100644
index 000000000000..6537d4774465
--- /dev/null
+++ b/dev-python/apiextractor/apiextractor-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apiextractor/apiextractor-0.3.3.ebuild,v 1.1 2010/01/20 23:38:16 ayoy Exp $
+
+EAPI="2"
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="Library used to create an internal representation of an API in order to create Python bindings"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=x11-libs/qt-core-4.5.0
+ >=x11-libs/qt-xmlpatterns-4.5.0"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -e 's:cmake-${CMAKE_MAJOR_VERSION}\.${CMAKE_MINOR_VERSION}:cmake:' \
+ -e '/^install/s/lib/lib${LIB_SUFFIX}/' \
+ -i CMakeLists.txt || die "sed failed"
+}
+
+src_test() {
+ # bug 299766
+ Xemake test -C "${CMAKE_BUILD_DIR}/tests" || die "running tests failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+}