summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-24 19:49:06 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-24 19:49:06 +0000
commit2e51d1c9f75edccf474b2d32369db5d2f7388af8 (patch)
tree3e2be0de146549a4ce49ff6970bba9d0971dbacd
parentvarious fixes (diff)
downloadgentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.tar.gz
gentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.tar.bz2
gentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.zip
Fix to only build static if we do not build c++, fortran, objc, or java
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-3.2.1-r6.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.2.1-r7.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r1.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.2.2-r3.ebuild32
-rw-r--r--sys-devel/gcc/gcc-3.2.2.ebuild11
7 files changed, 57 insertions, 37 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 03067072951f..4907ee9bf5fc 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.80 2003/03/24 02:59:25 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.81 2003/03/24 19:49:06 azarah Exp $
+
+ 24 Mar 2003; Martin Schlemmer <azarah@gentoo.org> :
+ Fix latest ebuild to only build static if we are just building the C
+ frontend, else some C++ packages fails when trying to link to libstdc++.so,
+ bug #18050.
*gcc-3.2.2-r2 (21 Mar 2003)
diff --git a/sys-devel/gcc/gcc-3.2.1-r6.ebuild b/sys-devel/gcc/gcc-3.2.1-r6.ebuild
index 570ec9540f81..f316d9bd9dc7 100644
--- a/sys-devel/gcc/gcc-3.2.1-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r6.ebuild,v 1.12 2003/02/13 20:18:56 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r6.ebuild,v 1.13 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -275,18 +275,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi
diff --git a/sys-devel/gcc/gcc-3.2.1-r7.ebuild b/sys-devel/gcc/gcc-3.2.1-r7.ebuild
index 4e39b0be1c41..5560ec9685eb 100644
--- a/sys-devel/gcc/gcc-3.2.1-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r7.ebuild,v 1.3 2003/02/13 16:31:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r7.ebuild,v 1.4 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -284,18 +284,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi
diff --git a/sys-devel/gcc/gcc-3.2.2-r1.ebuild b/sys-devel/gcc/gcc-3.2.2-r1.ebuild
index e8c1e4f2a7c7..3e3b8b33e62f 100644
--- a/sys-devel/gcc/gcc-3.2.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r1.ebuild,v 1.4 2003/03/09 03:23:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r1.ebuild,v 1.5 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -291,18 +291,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi
diff --git a/sys-devel/gcc/gcc-3.2.2-r2.ebuild b/sys-devel/gcc/gcc-3.2.2-r2.ebuild
index b40ab40396d2..f8e5bd79f5fa 100644
--- a/sys-devel/gcc/gcc-3.2.2-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r2.ebuild,v 1.1 2003/03/23 15:40:10 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r2.ebuild,v 1.2 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -302,18 +302,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi
diff --git a/sys-devel/gcc/gcc-3.2.2-r3.ebuild b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
index f0f404714e25..90ce9dc5a225 100644
--- a/sys-devel/gcc/gcc-3.2.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.5 2003/03/24 02:59:25 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2-r3.ebuild,v 1.6 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -192,12 +192,12 @@ src_unpack() {
cp ${FILESDIR}/3.2/protector.h ${WORKDIR}/${P}/gcc/
- # GCC bugfixes ...
- epatch ${FILESDIR}/3.2.2/gcc32-pr7768.patch
- epatch ${FILESDIR}/3.2.2/gcc32-pr8213.patch
-# epatch ${FILESDIR}/3.2.2/gcc32-pr9732.patch
-# epatch ${FILESDIR}/3.2.2/gcc322-pr9888.patch
- epatch ${FILESDIR}/3.2.2/gcc322-pr8746.patch
+ # GCC bugfixes ...
+ epatch ${FILESDIR}/3.2.2/gcc32-pr7768.patch
+ epatch ${FILESDIR}/3.2.2/gcc32-pr8213.patch
+# epatch ${FILESDIR}/3.2.2/gcc32-pr9732.patch
+# epatch ${FILESDIR}/3.2.2/gcc322-pr9888.patch
+ epatch ${FILESDIR}/3.2.2/gcc322-pr8746.patch
# Patches from debian-arm
if [ "${ARCH}" = "arm" ]
@@ -322,24 +322,24 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
-eerror "${CFLAGS}"
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
- BOOT_CFLAGS="${CFLAGS}" \
- STAGE1_CFLAGS="-O" || die
-
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ eerror "CFLAGS = ${CFLAGS}"
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
- BOOT_CFLAGS="${CFLAGS}" \
- STAGE1_CFLAGS="-O" || die
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi
}
diff --git a/sys-devel/gcc/gcc-3.2.2.ebuild b/sys-devel/gcc/gcc-3.2.2.ebuild
index 73f86990941e..dce442420102 100644
--- a/sys-devel/gcc/gcc-3.2.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.12 2003/03/09 03:23:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.13 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -287,18 +287,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi