summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-09-23 03:46:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-09-23 03:46:09 +0000
commit24ed9405fc977be08cf1ad355e2d80b2210402a0 (patch)
treeaf8286fdbfd85427f5bbe619159e46119e61a58a
parentMarked ppc64 stable for bug #191283. (diff)
downloadgentoo-2-24ed9405fc977be08cf1ad355e2d80b2210402a0.tar.gz
gentoo-2-24ed9405fc977be08cf1ad355e2d80b2210402a0.tar.bz2
gentoo-2-24ed9405fc977be08cf1ad355e2d80b2210402a0.zip
Bug #145655, version bump.
(Portage version: 2.1.3.7)
-rw-r--r--sys-libs/openipmi/ChangeLog9
-rw-r--r--sys-libs/openipmi/files/digest-openipmi-1.4.283
-rw-r--r--sys-libs/openipmi/files/digest-openipmi-2.0.113
-rw-r--r--sys-libs/openipmi/openipmi-1.4.28.ebuild41
-rw-r--r--sys-libs/openipmi/openipmi-2.0.11.ebuild69
5 files changed, 124 insertions, 1 deletions
diff --git a/sys-libs/openipmi/ChangeLog b/sys-libs/openipmi/ChangeLog
index 460ee1844181..44772e231cb7 100644
--- a/sys-libs/openipmi/ChangeLog
+++ b/sys-libs/openipmi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/openipmi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/ChangeLog,v 1.6 2007/02/22 00:40:25 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/ChangeLog,v 1.7 2007/09/23 03:46:08 robbat2 Exp $
+
+*openipmi-2.0.11 (23 Sep 2007)
+*openipmi-1.4.28 (23 Sep 2007)
+
+ 23 Sep 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +openipmi-1.4.28.ebuild, +openipmi-2.0.11.ebuild:
+ Bug #145655, version bump.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-libs/openipmi/files/digest-openipmi-1.4.28 b/sys-libs/openipmi/files/digest-openipmi-1.4.28
new file mode 100644
index 000000000000..5259e51d6030
--- /dev/null
+++ b/sys-libs/openipmi/files/digest-openipmi-1.4.28
@@ -0,0 +1,3 @@
+MD5 f63de901ddb96e67c5852504a51f5ef5 OpenIPMI-1.4.28.tar.gz 2310138
+RMD160 41f885aac02fa317236972faac65c08a96953f6c OpenIPMI-1.4.28.tar.gz 2310138
+SHA256 75fbff6c03c1bbea448aa8021aa2f0ee5c4f75f53600e0e479483ce2bf6d06ed OpenIPMI-1.4.28.tar.gz 2310138
diff --git a/sys-libs/openipmi/files/digest-openipmi-2.0.11 b/sys-libs/openipmi/files/digest-openipmi-2.0.11
new file mode 100644
index 000000000000..9abdc373c685
--- /dev/null
+++ b/sys-libs/openipmi/files/digest-openipmi-2.0.11
@@ -0,0 +1,3 @@
+MD5 2fdcb5be3730cf26e69bb20d29415710 OpenIPMI-2.0.11.tar.gz 2897970
+RMD160 edf2fe331ad32b202374dc6a21c8fc3032918866 OpenIPMI-2.0.11.tar.gz 2897970
+SHA256 9a824bc1faf69ef8e668dcc426c356b41abb4a18a7367c9fbbc87350df7b9cfa OpenIPMI-2.0.11.tar.gz 2897970
diff --git a/sys-libs/openipmi/openipmi-1.4.28.ebuild b/sys-libs/openipmi/openipmi-1.4.28.ebuild
new file mode 100644
index 000000000000..98b601f520f6
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-1.4.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-1.4.28.ebuild,v 1.1 2007/09/23 03:46:08 robbat2 Exp $
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="crypt snmp perl"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/libc
+ dev-libs/glib
+ >=dev-lang/swig-1.3.21
+ sys-libs/gdbm
+ dev-util/pkgconfig
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )"
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ myconf="${myconf} `use_with perl perl yes`"
+ myconf="${myconf} --with-swig=yes --with-glib=yes"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.emulator
+ newdoc cmdlang/README README.cmdlang
+}
diff --git a/sys-libs/openipmi/openipmi-2.0.11.ebuild b/sys-libs/openipmi/openipmi-2.0.11.ebuild
new file mode 100644
index 000000000000..227f75067257
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-2.0.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-2.0.11.ebuild,v 1.1 2007/09/23 03:46:08 robbat2 Exp $
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="crypt snmp perl tcl python"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/libc
+ dev-libs/glib
+ >=dev-lang/swig-1.3.21
+ sys-libs/gdbm
+ dev-util/pkgconfig
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )"
+# Gui is broken!
+# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+# Upstream doesn't use --without properly
+use_yesno() {
+ yesmsg="yes"
+ [ -n "$3" ] && yesmsg="$3"
+ if use $1; then
+ echo "--with-$2=${yesmsg}"
+ else
+ echo "--without-$2"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ myconf="${myconf} `use_with perl perl yes`"
+ myconf="${myconf} `use_with tcl tcl yes`"
+ myconf="${myconf} `use_with python python yes`"
+
+ # GUI is broken
+ #use tk && use python && use !tcl && \
+ # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+ #if use python && use tcl; then
+ # myconf="${myconf} `use_yesno tk tkinter yes`"
+ #else
+ # myconf="${myconf} `use_yesno tk tkinter no`"
+ #fi
+
+ myconf="${myconf} --without-tkinter"
+ myconf="${myconf} --with-glib --with-swig"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.emulator
+ newdoc cmdlang/README README.cmdlang
+}