summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-17 15:22:36 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-17 15:22:36 +0000
commit174c240ec7fa37e59cbb206beb598ec6866518b2 (patch)
tree98ed92bd66d3807591ebd25a4327dcb9d88489b3
parentVersion bump, bug #513538. (diff)
downloadgentoo-2-174c240ec7fa37e59cbb206beb598ec6866518b2.tar.gz
gentoo-2-174c240ec7fa37e59cbb206beb598ec6866518b2.tar.bz2
gentoo-2-174c240ec7fa37e59cbb206beb598ec6866518b2.zip
Add lazy2 & update bmp filter. Switch to new-style /usr/lib libexecdir.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--app-arch/zpaq-extras/ChangeLog7
-rw-r--r--app-arch/zpaq-extras/zpaq-extras-3.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-arch/zpaq-extras/ChangeLog b/app-arch/zpaq-extras/ChangeLog
index 8c34d8943668..22b367b09303 100644
--- a/app-arch/zpaq-extras/ChangeLog
+++ b/app-arch/zpaq-extras/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/zpaq-extras
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v 1.7 2014/02/19 16:57:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v 1.8 2014/06/17 15:22:36 mgorny Exp $
+
+*zpaq-extras-3 (17 Jun 2014)
+
+ 17 Jun 2014; Michał Górny <mgorny@gentoo.org> +zpaq-extras-3.ebuild:
+ Add lazy2 & update bmp filter. Switch to new-style /usr/lib libexecdir.
19 Feb 2014; Michał Górny <mgorny@gentoo.org> -zpaq-extras-1.ebuild:
Drop old.
diff --git a/app-arch/zpaq-extras/zpaq-extras-3.ebuild b/app-arch/zpaq-extras/zpaq-extras-3.ebuild
new file mode 100644
index 000000000000..543cf64089b8
--- /dev/null
+++ b/app-arch/zpaq-extras/zpaq-extras-3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/zpaq-extras-3.ebuild,v 1.1 2014/06/17 15:22:36 mgorny Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A set of additional compression profiles for app-arch/zpaq"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/bwt_j3.zip
+ http://mattmahoney.net/dc/bwt_slowmode1.zip
+ http://mattmahoney.net/dc/exe_j1.zip
+ http://mattmahoney.net/dc/jpg_test2.zip
+ http://mattmahoney.net/dc/min.zip
+ http://mattmahoney.net/dc/fast.cfg -> zpaq-fast.cfg
+ http://mattmahoney.net/dc/mid.cfg -> zpaq-mid.cfg
+ http://mattmahoney.net/dc/max.cfg -> zpaq-max.cfg
+ http://mattmahoney.net/dc/bmp_j4c.zip
+ http://mattmahoney.net/dc/lz1.zip
+ http://mattmahoney.net/dc/lazy100.zip
+ http://mattmahoney.net/dc/lazy210.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=app-arch/zpaq-6.19"
+
+S=${WORKDIR}
+
+src_unpack() {
+ local x
+ for x in ${A}; do
+ if [[ ${x} == *.cfg ]]; then
+ cp "${DISTDIR}"/${x} ${x#zpaq-} || die
+ fi
+ done
+
+ default
+}
+
+src_configure() {
+ sed \
+ -e "/^pcomp zpaq/s:-m:-m${EPREFIX}/usr/share/zpaq/:" \
+ -e "s:^pcomp zpaq:pcomp ${EPREFIX}/usr/bin/zpaq:" \
+ -e "s:^pcomp \([^/]\):pcomp ${EPREFIX}/usr/lib/zpaq/\1:" \
+ -i *.cfg || die
+
+ local sources=( *.cpp )
+ # (the following assignment flattens the array)
+ progs=${sources[@]%.cpp}
+}
+
+src_compile() {
+ tc-export CXX
+ emake ${progs} || die
+}
+
+src_install() {
+ exeinto /usr/lib/zpaq
+ doexe ${progs} || die
+
+ insinto /usr/share/zpaq
+ doins *.cfg || die
+}