summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-02-06 12:15:22 +0000
committerFabian Groffen <grobian@gentoo.org>2012-02-06 12:15:22 +0000
commit160eae6a6d791bc3e537f08a160df3c7e9b70eea (patch)
tree9af400366f76357bf36371acb07e145ac5fb6b9e
parentAdd nls use flag to pull in translations, fixes bug #402125. (diff)
downloadgentoo-2-160eae6a6d791bc3e537f08a160df3c7e9b70eea.tar.gz
gentoo-2-160eae6a6d791bc3e537f08a160df3c7e9b70eea.tar.bz2
gentoo-2-160eae6a6d791bc3e537f08a160df3c7e9b70eea.zip
Add patch to treat 32-bits 4GB overflow problem as warning on PowerPC next to ARM and i386.
(Portage version: 2.2.01.20062-prefix/cvs/SunOS i386)
-rw-r--r--sys-devel/binutils-apple/ChangeLog9
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.2.ebuild5
-rw-r--r--sys-devel/binutils-apple/files/ld64-127.2-ppc-range-warning.patch16
3 files changed, 26 insertions, 4 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index 3945d99f25f6..267b836402a3 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/binutils-apple
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.26 2011/11/08 14:02:59 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.27 2012/02/06 12:15:22 grobian Exp $
+
+ 06 Feb 2012; Fabian Groffen <grobian@gentoo.org>
+ +files/ld64-127.2-ppc-range-warning.patch, binutils-apple-4.2.ebuild:
+ Add patch to treat 32-bits 4GB overflow problem as warning on PowerPC next to
+ ARM and i386.
08 Nov 2011; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.2.ebuild:
Fix Darwin8 patch version in name
diff --git a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
index 4b98fdcc3491..4a4959299411 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.3 2011/11/08 14:02:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.4 2012/02/06 12:15:22 grobian Exp $
EAPI="3"
@@ -66,6 +66,7 @@ src_prepare() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/ld64-123.2-Makefile Makefile
epatch "${FILESDIR}"/${LD64}-lto.patch
+ epatch "${FILESDIR}"/${LD64}-ppc-range-warning.patch
ln -s ../../${CCTOOLS}/include
cp other/prune_trie.h include/mach-o/ || die
diff --git a/sys-devel/binutils-apple/files/ld64-127.2-ppc-range-warning.patch b/sys-devel/binutils-apple/files/ld64-127.2-ppc-range-warning.patch
new file mode 100644
index 000000000000..c9f850823939
--- /dev/null
+++ b/sys-devel/binutils-apple/files/ld64-127.2-ppc-range-warning.patch
@@ -0,0 +1,16 @@
+Insipred by the comment here:
+http://bugs.freepascal.org/view.php?id=20879
+It looks like the PPC case is missing, hence add this. Without, we get
+linker errors for compiling packages like Python and TexLive.
+
+--- src/ld/OutputFile.cpp
++++ src/ld/OutputFile.cpp
+@@ -807,7 +807,7 @@
+ // is encoded in mach-o the same as:
+ // .long _foo + 0x40000000
+ // so if _foo lays out to 0xC0000100, the first is ok, but the second is not.
+- if ( (_options.architecture() == CPU_TYPE_ARM) || (_options.architecture() == CPU_TYPE_I386) ) {
++ if ( (_options.architecture() == CPU_TYPE_ARM) || (_options.architecture() == CPU_TYPE_I386) || (_options.architecture() == CPU_TYPE_POWERPC) ) {
+ // Unlikely userland code does funky stuff like this, so warn for them, but not warn for -preload
+ if ( _options.outputKind() != Options::kPreload ) {
+ warning("32-bit absolute address out of range (0x%08llX max is 4GB): from %s + 0x%08X (0x%08llX) to 0x%08llX",