summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-02 06:47:26 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-02 06:47:26 +0000
commit1374d1d67571ff3aca09ba67a7ea3707fc0778bf (patch)
tree61cc98bd09cf93456020f2f23d842ba42ea29ab3
parentfix fcitx version (diff)
downloadgentoo-2-1374d1d67571ff3aca09ba67a7ea3707fc0778bf.tar.gz
gentoo-2-1374d1d67571ff3aca09ba67a7ea3707fc0778bf.tar.bz2
gentoo-2-1374d1d67571ff3aca09ba67a7ea3707fc0778bf.zip
Version bump. Install new man page.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-ruby/bluecloth/ChangeLog7
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index adfba66cf1ed..fa9e919902b7 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.53 2011/08/20 12:40:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.54 2011/11/02 06:47:26 graaff Exp $
+
+*bluecloth-2.2.0 (02 Nov 2011)
+
+ 02 Nov 2011; Hans de Graaff <graaff@gentoo.org> +bluecloth-2.2.0.ebuild:
+ Version bump. Install new man page.
20 Aug 2011; Hans de Graaff <graaff@gentoo.org> -bluecloth-2.0.5.ebuild,
-bluecloth-2.0.11.ebuild:
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild
new file mode 100644
index 000000000000..893955dfe6da
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.2.0.ebuild,v 1.1 2011/11/02 06:47:26 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND="${DEPEND} doc? ( dev-lang/perl )"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/rspec-2.4:2
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+}
+
+all_ruby_compile() {
+ rake man/man1/bluecloth.1
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die "tests failed"
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}