summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-04-05 15:51:04 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-04-05 15:51:04 +0000
commit0608d2560356261e7c621158b6b63ca2ab0dac78 (patch)
tree891c2c6bd64963e97eac1c4ea6c55e1aff953acb
parentFixed RDEPEND syntax (Bug #128774) (diff)
downloadgentoo-2-0608d2560356261e7c621158b6b63ca2ab0dac78.tar.gz
gentoo-2-0608d2560356261e7c621158b6b63ca2ab0dac78.tar.bz2
gentoo-2-0608d2560356261e7c621158b6b63ca2ab0dac78.zip
* bump
(Portage version: 2.1_pre7-r4)
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest6
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.363
-rw-r--r--www-servers/nginx/nginx-0.3.36.ebuild72
4 files changed, 87 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index c48ac5be7175..0220bf45587b 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.81 2006/03/23 09:51:28 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.82 2006/04/05 15:51:04 voxus Exp $
+
+*nginx-0.3.36 (05 Apr 2006)
+
+ 05 Apr 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.36.ebuild:
+ Version bump.
*nginx-0.3.35 (23 Mar 2006)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 7fa7a5155ae0..5b7a938d0c86 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -13,6 +13,9 @@ SHA256 7a964f8c05d49c4b8c87fb941579122794d754b1855e9abf66120c577327a95a files/di
MD5 60327ac70ee8e62fe89685ba738fe323 files/digest-nginx-0.3.35 238
RMD160 81d259e956ab1d203a61b71f9e28f1b5c22eb10a files/digest-nginx-0.3.35 238
SHA256 e5b0f3bb2bab08fa79182d0508ab326b87b0f273499606560e209c8628217419 files/digest-nginx-0.3.35 238
+MD5 714c24a0690e0af29fb1d22a600f8e09 files/digest-nginx-0.3.36 238
+RMD160 ee75b944c3bcc97170fe1dd40dc454b46000ca07 files/digest-nginx-0.3.36 238
+SHA256 849e0fb94d6f8b2daa88ef6d43cb43161d2a51fa613b078b7ceaa96d1e933b62 files/digest-nginx-0.3.36 238
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
RMD160 4b36e15714c84f8e8228d0ca6790c545736d74bb files/nginx 994
SHA256 17a32f38e066ecc91ad91496e0ab8f0885e5550d42bf62dbecfdf2747a0fb1cd files/nginx 994
@@ -40,3 +43,6 @@ SHA256 4b886077a85f3753f21909c2f0f1aac8744d9c8b9816198c37f5ca4f89bc40f4 nginx-0.
MD5 29eeccbf7428b49ac33f2837f44af70a nginx-0.3.35.ebuild 2082
RMD160 139f38f68ff85cdd9865a02c4f838642f99086e9 nginx-0.3.35.ebuild 2082
SHA256 70301b4c980453cbd32d86dbe95eeec2344115ee06d8bc5e073d985c067ee9f9 nginx-0.3.35.ebuild 2082
+MD5 29eeccbf7428b49ac33f2837f44af70a nginx-0.3.36.ebuild 2082
+RMD160 139f38f68ff85cdd9865a02c4f838642f99086e9 nginx-0.3.36.ebuild 2082
+SHA256 70301b4c980453cbd32d86dbe95eeec2344115ee06d8bc5e073d985c067ee9f9 nginx-0.3.36.ebuild 2082
diff --git a/www-servers/nginx/files/digest-nginx-0.3.36 b/www-servers/nginx/files/digest-nginx-0.3.36
new file mode 100644
index 000000000000..5cd565966abf
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.36
@@ -0,0 +1,3 @@
+MD5 1a2135d9506a79192f476e02cd8a8589 nginx-0.3.36.tar.gz 384877
+RMD160 292ff011151221d1ab5ab28033ab19d11bd7aca0 nginx-0.3.36.tar.gz 384877
+SHA256 24ee01f244d67329986c6bbe8209eb0b293ac1d627b8825da4374c38d03d33c0 nginx-0.3.36.tar.gz 384877
diff --git a/www-servers/nginx/nginx-0.3.36.ebuild b/www-servers/nginx/nginx-0.3.36.ebuild
new file mode 100644
index 000000000000..8af1dd1e3fb2
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.36.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.36.ebuild,v 1.1 2006/04/05 15:51:04 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}