aboutsummaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2004-11-20 10:17:11 +0000
committerBrian Harring <ferringb@gentoo.org>2004-11-20 10:17:11 +0000
commit027af1e79f8ad56dfdd6e9795bf6132e02365b9a (patch)
tree27c974d327a921f53cfcea130eb34aaf9e2cd503 /src
parentoops. commited wrong base file. :) (diff)
downloadportage-cvs-027af1e79f8ad56dfdd6e9795bf6132e02365b9a.tar.gz
portage-cvs-027af1e79f8ad56dfdd6e9795bf6132e02365b9a.tar.bz2
portage-cvs-027af1e79f8ad56dfdd6e9795bf6132e02365b9a.zip
autotooling fun.
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am16
-rwxr-xr-xsrc/python-missingos/Makefile.in25
2 files changed, 41 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1e04f34
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS =
+
+bin_PROGRAMS =
+if BUILD_TBZ2TOOL
+bin_PROGRAMS += tbz2tool
+endif
+
+if BUILD_FILTER_ENV
+SUBDIRS += filter-env
+endif
+
+if BUILD_MISSINGOS
+SUBDIRS += python-missingos
+endif
+
+tbz2tool_SOURCES = tbz2tool.c
diff --git a/src/python-missingos/Makefile.in b/src/python-missingos/Makefile.in
new file mode 100755
index 0000000..e368143
--- /dev/null
+++ b/src/python-missingos/Makefile.in
@@ -0,0 +1,25 @@
+INSTALL = @INSTALL@
+
+all:
+ setup.py build
+
+install:
+ setup.py install --root $(DESTDIR)
+
+DISTFILES = setup.py \
+ Makefile.in \
+ PKG-INFO \
+ README \
+ missingos.c \
+ setup.cfg \
+ ChangeLog
+distdir:
+ for x in $(DISTFILES); do \
+ $(INSTALL) -D $$x $(distdir)/$$x; \
+ done
+ chmod 755 $(distdir)/setup.py
+
+
+clean:
+.PHONY: clean install all distdir
+