aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbin/runtests5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/runtests b/bin/runtests
index 5060cf3..8ac52be 100755
--- a/bin/runtests
+++ b/bin/runtests
@@ -1,10 +1,11 @@
#!/bin/bash
-while getopts sa:dc arg; do
+while getopts sa:dcf arg; do
case ${arg} in
s) SETTINGS="--settings=okupy.tests.settings" ;;
d) TDAEMON="tdaemon -t django" ;;
c) COVERAGE="coverage" ;;
+ f) FLAKE8="flake8 . --exclude=./okupy/tests/settings.py,./okupy/settings,setup.py" ;;
2) SUFFIX="2" ;;
esac
done
@@ -20,3 +21,5 @@ else
echo "Executing: $COMMAND"
$COMMAND
fi
+
+${FLAKE8}