summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/patchsets/mico/9999/006_all_as-needed.patch')
-rw-r--r--src/patchsets/mico/9999/006_all_as-needed.patch25
1 files changed, 20 insertions, 5 deletions
diff --git a/src/patchsets/mico/9999/006_all_as-needed.patch b/src/patchsets/mico/9999/006_all_as-needed.patch
index f99889f3bf..c115defc87 100644
--- a/src/patchsets/mico/9999/006_all_as-needed.patch
+++ b/src/patchsets/mico/9999/006_all_as-needed.patch
@@ -1,8 +1,20 @@
-Link libmico.so against configured libraries,
-to get -Wl,--as-needed working. #280678.
---- mico/orb/Makefile
-+++ mico/orb/Makefile
-@@ -30,7 +30,7 @@
+From 076ba1ccc04b7478988bed0283c1dcf358d9d9a3 Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Tue, 21 May 2019 17:57:29 +0200
+Subject: [PATCH 07/19] link libmico.so against detected libraries
+
+Link shared libmico.so against configure detected libraries to avoid
+undefined symbols, to let --as-needed linker flag work if forced.
+See also: https://bugs.gentoo.org/280678
+---
+ orb/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/orb/Makefile b/orb/Makefile
+index 2bf0627..39e8e93 100644
+--- a/orb/Makefile
++++ b/orb/Makefile
+@@ -30,7 +30,7 @@ CXXFLAGS := -DBUILD_MICO_DLL $(CXXFLAGS)
endif
endif
@@ -11,3 +23,6 @@ to get -Wl,--as-needed working. #280678.
ifeq ($(HAVE_CYGWIN), yes)
ifeq ($(USE_CSL2), yes)
PLATFORM_LIBS := $(PLATFORM_LIBS) -lssl -lcrypto
+--
+2.19.2
+