summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorArtur Maciąg <maciag.artur@gmail.com>2010-04-22 17:11:36 +0200
committerArtur Maciąg <maciag.artur@gmail.com>2010-04-22 17:11:36 +0200
commit3bffa8f9899ad120108019ad8cd2267392beb929 (patch)
treeb71cc6e46d6312125d36d30a158edbf3cfb844b3 /net-im
parenttlenlinux version bump (diff)
downloadpiczu-3bffa8f9899ad120108019ad8cd2267392beb929.tar.gz
piczu-3bffa8f9899ad120108019ad8cd2267392beb929.tar.bz2
piczu-3bffa8f9899ad120108019ad8cd2267392beb929.zip
Revert "tlenlinux version bump"
This reverts commit 8f43d61d55af51252692cc167c234c73c7e5b614.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/tlenlinux/tlenlinux-7.0.1.63.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/net-im/tlenlinux/tlenlinux-7.0.1.63.ebuild b/net-im/tlenlinux/tlenlinux-7.0.1.63.ebuild
deleted file mode 100644
index 1420580..0000000
--- a/net-im/tlenlinux/tlenlinux-7.0.1.63.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit fdo-mime eutils
-
-DESCRIPTION="Tlen IM client"
-HOMEPAGE="http://tlen.pl"
-SRC_URI="
- amd64? ( http://j.o2.pl/idi/${PN}64-${PV}.bin )
- x86? ( http://j.o2.pl/idi/${P}.bin )"
-
-LICENSE="tlen"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt-static"
-PROPERTIES="interactive"
-RESTRICT="strip"
-
-RDEPEND="x11-misc/xdg-utils
- !qt-static? ( x11-libs/qt-gui:4
- x11-libs/qt-phonon:4 )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-TLEN_DIR="/opt/tlen"
-STATIC_FILES="designer/* imageformats/* phonon_backend/* qt_libs/*"
-SHARED_FILES="plugins/* tlen_libs/* tlen-bin updater"
-
-src_unpack() {
- unpack_makeself
-}
-
-src_prepare() {
- cd data
- # Fix RPATH
- if use qt-static; then
- # Change RPATH
- ./chrpath -r ${TLEN_DIR}/qt_libs:${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
- ./chrpath -r ${TLEN_DIR}/qt_libs ${STATIC_FILES} > /dev/null
- else
- # Change RPATH
- ./chrpath -r ${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
- # Disable LD and QT unsets
- sed -i "s:unset:# unset:" tlen
- # Remove unneeded libs
- rm -rf qt_libs imageformats phonon_backend
- fi
- # Desktop icon fix
- sed -i "s:.jpg:.png:" ${S}/tlen.desktop
-}
-
-src_install() {
- # Prepare directory
- dodir ${TLEN_DIR}
- # Copy data
- cp -r data/* ${D}/${TLEN_DIR} || die "cp failed"
- # Install desktop file
- insinto /usr/share/applications/
- doins tlen.desktop
- # Install mime type
- insinto /usr/share/mime/packages/
- doins tlen.pl-extension.xml
- # Install symlink
- dodir /usr/bin
- dosym ${TLEN_DIR}/tlen /usr/bin/tlen
-}
-
-pkg_preinst() {
- check_license
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- ### @todo deactivate auto-update by default
- elog
- elog "It is not recommended to use Updater plugin."
- elog "You should deselect Updater in:"
- elog "\"Tlen\" -> \"Preferences\" -> \"Plugins\"."
- elog
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}