summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-16 06:59:30 +0100
committerMartin Väth <martin@mvath.de>2016-12-16 06:59:30 +0100
commit8ea75b13f13d805665b1b25fb3f95933e27f6ced (patch)
treeeb862b22597cfe2e4ef638803eb8e6cb45621fde /media-tv
parentsci-mathematics/reduce: Fix compilation with gcc-6 (diff)
downloadmv-8ea75b13f13d805665b1b25fb3f95933e27f6ced.tar.gz
mv-8ea75b13f13d805665b1b25fb3f95933e27f6ced.tar.bz2
mv-8ea75b13f13d805665b1b25fb3f95933e27f6ced.zip
media-tv/nvtv: Add from gentoo repository to fix autotools issues
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/nvtv/Manifest1
-rw-r--r--media-tv/nvtv/files/nvtv.start21
-rw-r--r--media-tv/nvtv/files/respect-cflags.patch31
-rw-r--r--media-tv/nvtv/metadata.xml9
-rw-r--r--media-tv/nvtv/nvtv-0.4.7-r3.ebuild45
5 files changed, 107 insertions, 0 deletions
diff --git a/media-tv/nvtv/Manifest b/media-tv/nvtv/Manifest
new file mode 100644
index 00000000..40b01103
--- /dev/null
+++ b/media-tv/nvtv/Manifest
@@ -0,0 +1 @@
+DIST nvtv-0.4.7.tar.gz 419564 SHA256 f044c6de2df66196fa589ed0d33203bd10d88604f447befce1a6f62eb7b08dac SHA512 086de916b3b783a2071906e8f2eb98009f2f73627dc75ee086bde9864de3fb18ddf6d981c56225ac3dca3c837ff3575deb2aeca042be4cca9dc7a876cc41282d WHIRLPOOL c5ac613d4331f62c761addc321f3b619dc73206b5c5d5bbf75cbb7e261537521f8f67cbc4ea154dc89c9ebcba6b95c08b7b78569c50f8d2f895481b7aefc4a11
diff --git a/media-tv/nvtv/files/nvtv.start b/media-tv/nvtv/files/nvtv.start
new file mode 100644
index 00000000..76091c18
--- /dev/null
+++ b/media-tv/nvtv/files/nvtv.start
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use modules logger
+}
+
+start() {
+ ebegin "Starting NVidia TV-Out Server"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nvtvd \
+ --background 1>&2
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NVidia TV-Out Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nvtvd 1>&2
+ eend $?
+}
diff --git a/media-tv/nvtv/files/respect-cflags.patch b/media-tv/nvtv/files/respect-cflags.patch
new file mode 100644
index 00000000..2fa991f7
--- /dev/null
+++ b/media-tv/nvtv/files/respect-cflags.patch
@@ -0,0 +1,31 @@
+The rest of the build system will respect the user's CFLAGS if we
+don't wipe them out, so just delete the line that does that. The
+removal of the gtk-1.x stuff is so that we can run eautoreconf and
+have it work; we don't support gtk1 in Gentoo anyway.
+
+diff --git a/configure.in b/configure.in
+index f8f48cc..d8f1261 100755
+--- a/configure.in
++++ b/configure.in
+@@ -57,9 +57,6 @@ dnl
+ dnl Debugging enables, CFLAGS
+ dnl
+
+-dnl Clear -g -O2 from CFLAGS
+-CFLAGS=""
+-
+ AC_MSG_CHECKING(for debugging info)
+
+ AC_ARG_ENABLE(debug,
+@@ -110,11 +107,6 @@ if test ${with_gtk} = no ; then
+ fi
+
+ if test ${have_gtk} = no ; then
+- if test ${with_gtk} = yes -o ${with_gtk} = gtk1 ; then
+- AM_PATH_GTK(1.2.0, have_gtk=gtk1)
+- fi
+-fi
+-if test ${have_gtk} = no ; then
+ if test ${with_gtk} = yes -o ${with_gtk} = gtk2 ; then
+ AM_PATH_GTK_2_0(2.0.0, have_gtk=gtk2)
+ fi
diff --git a/media-tv/nvtv/metadata.xml b/media-tv/nvtv/metadata.xml
new file mode 100644
index 00000000..3f29b9b2
--- /dev/null
+++ b/media-tv/nvtv/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>TV-Out for NVidia cards</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nv-tv-out</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-tv/nvtv/nvtv-0.4.7-r3.ebuild b/media-tv/nvtv/nvtv-0.4.7-r3.ebuild
new file mode 100644
index 00000000..2d164aca
--- /dev/null
+++ b/media-tv/nvtv/nvtv-0.4.7-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+IUSE="X gtk"
+
+DESCRIPTION="TV-Out for NVidia cards"
+HOMEPAGE="https://sourceforge.net/projects/nv-tv-out/"
+SRC_URI="mirror://sourceforge/nv-tv-out/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="sys-apps/pciutils[-zlib]
+ gtk? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xf86vidmodeproto )"
+
+PATCHES=( "${FILESDIR}/respect-cflags.patch" )
+
+src_prepare() {
+ default
+ sed -e 's/^\(.*_WXCONFIG.*\)/#\1/' -- configure.in >configure.ac || die
+ rm -- configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with gtk) $(use_with X x)
+}
+
+src_install() {
+ dobin src/nvtv
+ dosbin src/nvtvd
+ dodoc ANNOUNCE BUGS FAQ README doc/*.txt doc/USAGE
+ newinitd "${FILESDIR}"/nvtv.start nvtv
+}