summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-08-04 07:07:33 +0200
committerMartin Väth <martin@mvath.de>2022-08-04 07:07:33 +0200
commitc082528908270921b7f993973f45d847c7198fad (patch)
tree6d5d33ff01700d2e7f19166a9fab099f10fbeb24
parentmedia-gfx/ipe: Fix moc path for building with current qtcore on gentoo (diff)
downloadmv-c082528908270921b7f993973f45d847c7198fad.tar.gz
mv-c082528908270921b7f993973f45d847c7198fad.tar.bz2
mv-c082528908270921b7f993973f45d847c7198fad.zip
media-gfx/ipe: Version bump, adding app-text/qtspell as new dependency
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--app-text/qtspell/Manifest1
-rw-r--r--app-text/qtspell/metadata.xml15
-rw-r--r--app-text/qtspell/qtspell-1.0.1.ebuild24
-rw-r--r--media-gfx/ipe/Manifest2
-rw-r--r--media-gfx/ipe/ipe-7.2.26.ebuild (renamed from media-gfx/ipe/ipe-7.2.24.ebuild)3
-rw-r--r--metadata/pkg_desc_index3
6 files changed, 45 insertions, 3 deletions
diff --git a/app-text/qtspell/Manifest b/app-text/qtspell/Manifest
new file mode 100644
index 00000000..83de8c93
--- /dev/null
+++ b/app-text/qtspell/Manifest
@@ -0,0 +1 @@
+DIST qtspell-1.0.1.tar.gz 59732 BLAKE2B dfd380010657ca938244c7314c97961702c2004126757982ba9b5dbc72b4dc0e37dfdae95cc5b552293b4fee5a9b89dff4b82243e940a17c3909561671a534f5 SHA512 209f35fdb247a932a836ff95ad9bf5bd351b158a07f7f0469eed6a6ff20d447b39693d050abc4ece6a5b10e79fdaecc7a5859b481838592befd3c993a9ef1e25
diff --git a/app-text/qtspell/metadata.xml b/app-text/qtspell/metadata.xml
new file mode 100644
index 00000000..2b45f00d
--- /dev/null
+++ b/app-text/qtspell/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>manisandro@gmail.com</email>
+ <name>Sandro Mani</name>
+ </maintainer>
+ <remote-id type="github">manisandro/qtspell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/qtspell/qtspell-1.0.1.ebuild b/app-text/qtspell/qtspell-1.0.1.ebuild
new file mode 100644
index 00000000..025db97e
--- /dev/null
+++ b/app-text/qtspell/qtspell-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Spell checking for Qt text widgets"
+HOMEPAGE="https://github.com/manisandro/qtspell"
+SRC_URI="https://github.com/manisandro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/enchant"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ filter-flags '-flto*' '-fuse-linker-plugin' '-emit-llvm'
+ cmake_src_prepare
+}
diff --git a/media-gfx/ipe/Manifest b/media-gfx/ipe/Manifest
index 8daa4a9b..67464e3f 100644
--- a/media-gfx/ipe/Manifest
+++ b/media-gfx/ipe/Manifest
@@ -1 +1 @@
-DIST ipe-7.2.24-src.tar.gz 1031794 BLAKE2B 848d75eaf88ab4f576f71d8157e4b8735ff179fa3d9c09ca76069b7ea5fb4af7044c3d2b641b67de68efbea5ed053ff2288915dc113b8236a7aa46c6c2e22187 SHA512 4387f5d770e356f7103787c667a5ee9a588f5fa656b96e1cf33051efe62dfdd5fd3bb49f0fcbad5fd1f342e79e3dc110910e6f4a929ed57a6831b867bd84f56d
+DIST ipe-7.2.26-src.tar.gz 1034821 BLAKE2B b9224b38f6b1181515880f3e542e20825e7fae41dcff6464cb4d1dfdf7c36502e3d6ee4d2b99c2343d64a4b91448d12f91fe4d94a6ac2b35775b50770b4ab4e4 SHA512 f18fadcc0d7fb51d27597890f9620a5ad8edc91cacc8bf5af79a9c69af6044495f7f56780778387f754ad67c5be67b599376c91eb502e94cf38ac47fde95dfae
diff --git a/media-gfx/ipe/ipe-7.2.24.ebuild b/media-gfx/ipe/ipe-7.2.26.ebuild
index a9089b28..7f807df9 100644
--- a/media-gfx/ipe/ipe-7.2.24.ebuild
+++ b/media-gfx/ipe/ipe-7.2.26.ebuild
@@ -29,7 +29,8 @@ DEPEND="${LUA_DEPS}
sys-libs/zlib
x11-libs/cairo
dev-qt/qtcore:5
- dev-qt/qtgui:5"
+ dev-qt/qtgui:5
+ app-text/qtspell"
RDEPEND="${DEPEND}
|| ( app-text/texlive-core net-misc/curl )"
BDEPEND="virtual/pkgconfig"
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 5dfaff41..ab69bb93 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -51,6 +51,7 @@ app-shells/zshrc-mv 6.8: A zshrc file initializing zsh specific interactive feat
app-text/ispell 3.4.00-r1: fast screen-oriented spelling checker
app-text/mbtpdfasm 1.0.28-r1: Tool to assemble/merge, extract information from, and update the metadata in PDF
app-text/psjoin 0.3: concatenate postscript files. From new PostScript Utilities
+app-text/qtspell 1.0.1: Spell checking for Qt text widgets
app-text/stardict 3.0.6-r4 4.0.0_pre20170304-r1: A international dictionary supporting fuzzy and glob style matching
dev-cpp/cpplint 99999999: The google styleguide together with cpplint and an emacs file
dev-libs/osformat 1.0.7 999999999: C++ library for a typesafe printf/sprintf based on << conversion
@@ -72,7 +73,7 @@ games-rpg/aklabeth 1.0-r1: A remake of Richard C. Garriott's Ultima prequel
games-rpg/dsa-stats 1.1: calculate stat probabalities for the role playing game DSA - Das schwarze Auge
games-rpg/m5figur-mv 4.2.2: LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)
gui-wm/wayfire 0.7.3: compiz like 3D wayland compositor
-media-gfx/ipe 7.2.24-r1: Drawing editor for creating figures in PDF or PS formats
+media-gfx/ipe 7.2.26: Drawing editor for creating figures in PDF or PS formats
media-gfx/libspiro 20200505-r1: A spline computation library
media-gfx/pqiv 2.11: powerful GTK based command-line image viewer with a minimal UI
media-libs/avidemux-core 2.7.8: Core libraries for simple video cutting, filtering and encoding tasks