From 35c0594240b0d72c32ffc5ef9bf8921820b67bd3 Mon Sep 17 00:00:00 2001
From: "Anna (cybertailor) Vyalkova" <cyber+gentoo@sysrq.in>
Date: Tue, 31 May 2022 12:06:37 +0500
Subject: dev-python/vttlib: update EAPI 7 -> 8

Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
---
 dev-python/vttlib/vttlib-0.11.0.ebuild | 22 +++++++++-------------
 1 file changed, 9 insertions(+), 13 deletions(-)

(limited to 'dev-python/vttlib/vttlib-0.11.0.ebuild')

diff --git a/dev-python/vttlib/vttlib-0.11.0.ebuild b/dev-python/vttlib/vttlib-0.11.0.ebuild
index 42e9ca0ea..fda92c59c 100644
--- a/dev-python/vttlib/vttlib-0.11.0.ebuild
+++ b/dev-python/vttlib/vttlib-0.11.0.ebuild
@@ -1,43 +1,39 @@
 # Copyright 1999-2021 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="7"
+EAPI=8
 
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-MYPN="vttLib"
-MYPV="${PV/_p/.post}"
-MYP="${MYPN}-${MYPV}"
+DISTUTILS_USE_PEP517=setuptools
 PYTHON_COMPAT=( python3_{8..9} )
-
 inherit distutils-r1
 
+MY_PN="vttLib"
+MY_PV="${PV/_p/.post}"
+MY_P="${MY_PN}-${MY_PV}"
 DESCRIPTION="Dump, merge and compile Visual TrueType data in UFO3 with FontTools"
 HOMEPAGE="
 	https://github.com/daltonmaag/vttLib
 	https://pypi.org/project/vttlib/
 "
-SRC_URI="mirror://pypi/${MYP:0:1}/${MYPN}/${MYP}.zip"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.zip"
+S="${WORKDIR}/${MY_P}"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64"
 
-#install_requires
 RDEPEND="
 	>=dev-python/fonttools-4.10.2[${PYTHON_USEDEP}]
 	>=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
 	>=dev-python/ufoLib2-0.7.1[${PYTHON_USEDEP}]
 "
-#setup_requires
-DEPEND="
-	${RDEPEND}
+BDEPEND="
+	app-arch/unzip
 	dev-python/setuptools_scm[${PYTHON_USEDEP}]
 	dev-python/wheel[${PYTHON_USEDEP}]
 	test? (
 		>=dev-python/ufo2ft-2.14.0[${PYTHON_USEDEP}]
 	)
 "
-BDEPEND="app-arch/unzip"
-S="${WORKDIR}/${MYP}"
 
 distutils_enable_tests pytest
-- 
cgit v1.2.3-65-gdbad