aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mpv-plugin/mpv-mpris')
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.9-r2.ebuild (renamed from mpv-plugin/mpv-mpris/mpv-mpris-0.9-r1.ebuild)5
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.9-r1.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.9-r2.ebuild
index a9bcf1de1..f5ef84c62 100644
--- a/mpv-plugin/mpv-mpris/mpv-mpris-0.9-r1.ebuild
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-0.9-r2.ebuild
@@ -42,6 +42,11 @@ MPV_PLUGIN_FILES=( mpris.so )
RESTRICT="!test? ( test )"
+src_prepare() {
+ sed -e 's:-O2 ::' -i Makefile || die "sed Makefile(s) failed"
+ default
+}
+
src_compile() {
tc-export CC
emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
index 33adfb1da..f5ef84c62 100644
--- a/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
@@ -19,9 +19,10 @@ fi
LICENSE="MIT"
IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/glib:2"
+RDEPEND="
+ dev-libs/glib:2
+"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
@@ -39,6 +40,13 @@ BDEPEND="
MPV_PLUGIN_FILES=( mpris.so )
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ sed -e 's:-O2 ::' -i Makefile || die "sed Makefile(s) failed"
+ default
+}
+
src_compile() {
tc-export CC
emake PKG_CONFIG="$(tc-getPKG_CONFIG)"