aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/imhex/Manifest4
-rw-r--r--app-editors/imhex/files/remove-Werror.patch44
-rw-r--r--app-editors/imhex/files/require-llvm-16.patch17
-rw-r--r--app-editors/imhex/imhex-1.32.2.ebuild (renamed from app-editors/imhex/imhex-1.31.0.ebuild)17
4 files changed, 11 insertions, 71 deletions
diff --git a/app-editors/imhex/Manifest b/app-editors/imhex/Manifest
index 5765ebdb4..132a5445d 100644
--- a/app-editors/imhex/Manifest
+++ b/app-editors/imhex/Manifest
@@ -1,2 +1,2 @@
-DIST imhex-1.31.0.tar.gz 25062606 BLAKE2B 9db337f5aa54ccefd925175f8b4869ece873a7c466d6ddded88c26d6f4fd7ba73a7789964ad2ae6a902d2ec653980ef2482434ddcbbbc224aaac8906b16e92c5 SHA512 483a89e84746ba74eb968f84140ae52edb7046d1074160a97eb6ebad6eac0284beccaf39004141cbe1eebcd8ca92d1fd486c45790880503bbcc40c7bdd586cb8
-DIST imhex-patterns-1.31.0.tar.gz 4448476 BLAKE2B 0bace799f0d2280ccd11a1fcafa9d22620a74691f6b5622d3ad0e260143792c8239158ba021de8e775d5d8589f6dfee990d25beab4288c053d9a5b138b8cc252 SHA512 aaeb2028bbc8235fb49ba75bdca71acf725da0035395c86df97c3976bb70f33ad34f9ce3089d72141de6767cc511c575cc3ac85b66ee4eeba8caa252fc874dba
+DIST imhex-1.32.2.tar.gz 26875075 BLAKE2B 75d595e5acb05429b114f4d4c61981080797f7b88d41a219c93f6512c4b204dd164a8886c00af4ee539cb7d6f7baaa49084b349806357fb872a1ebb30e82cfba SHA512 72e3fda050220fa9098f4ad9ed1777db565c81549daf09a5d113e35036d26780ab50c5a45ddf97ec6daa22e832a0d0b916097082706bd7314d56c2f97abcbb11
+DIST imhex-patterns-1.32.2.tar.gz 4556923 BLAKE2B b171669c17c0a7aef0ba65b66c2f68f7581a8e11d61365363fd28cfedfa2658c8833181d5e8a4c789ff011c5afadafec8149b43852319cae161c9bb5c26be2ec SHA512 3f6d1c874e1d6bc4e2e035361c5c7c1da4374cfcaeb6123f187302cacf91ce781db3f4fbe74e259e1bdb18418987fe48067365dcc3324190fbadcaf0b5ab9333
diff --git a/app-editors/imhex/files/remove-Werror.patch b/app-editors/imhex/files/remove-Werror.patch
deleted file mode 100644
index e00aad737..000000000
--- a/app-editors/imhex/files/remove-Werror.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 94126d5ff7e5a6d6cdd7f515097383619725953b Mon Sep 17 00:00:00 2001
-From: Leoriem-code <henrigasc@duck.com>
-Subject: [PATCH] remove -Werror
-
-diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
-index da078878..3848fbeb 100644
---- a/cmake/build_helpers.cmake
-+++ b/cmake/build_helpers.cmake
-@@ -435,7 +435,7 @@ endfunction()
- macro(setupCompilerFlags target)
- if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
- if (IMHEX_STRICT_WARNINGS)
-- set(IMHEX_COMMON_FLAGS "-Wall -Wextra -Wpedantic -Werror")
-+ set(IMHEX_COMMON_FLAGS "-Wall -Wextra -Wpedantic")
- endif()
-
- set(IMHEX_C_FLAGS "${IMHEX_COMMON_FLAGS} -Wno-array-bounds")
-
-diff --git a/lib/external/pattern_language/cli/CMakeLists.txt b/lib/external/pattern_language/cli/CMakeLists.txt
-index 39e6f90..01b5e87 100644
---- a/lib/external/pattern_language/cli/CMakeLists.txt
-+++ b/lib/external/pattern_language/cli/CMakeLists.txt
-@@ -28,7 +28,7 @@ if(NOT CLI11_FOUND)
- set(CLI11_LIBRARIES CLI11::CLI11)
- endif()
-
--target_compile_options(plcli PRIVATE -Wall -Wextra -Werror -Wno-unknown-pragmas -Wno-array-bounds)
-+target_compile_options(plcli PRIVATE -Wall -Wextra -Wno-unknown-pragmas -Wno-array-bounds)
- target_include_directories(plcli PUBLIC include)
- target_link_libraries(plcli PUBLIC ${CLI11_LIBRARIES} libpl libpl-gen fmt::fmt-header-only)
-
-diff --git a/lib/external/pattern_language/lib/CMakeLists.txt b/lib/external/pattern_language/lib/CMakeLists.txt
-index dab1499..0bfac35 100644
---- a/lib/external/pattern_language/lib/CMakeLists.txt
-+++ b/lib/external/pattern_language/lib/CMakeLists.txt
-@@ -71,7 +71,7 @@ add_library(libpl ${LIBRARY_TYPE}
- )
-
- if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
-- target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas -Wno-array-bounds)
-+ target_compile_options(libpl PRIVATE -Wall -Wextra -Wpedantic -Wno-unknown-pragmas -Wno-array-bounds)
- if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
- target_compile_options(libpl PRIVATE -Wno-stringop-overflow)
- endif()
diff --git a/app-editors/imhex/files/require-llvm-16.patch b/app-editors/imhex/files/require-llvm-16.patch
deleted file mode 100644
index 7642e7654..000000000
--- a/app-editors/imhex/files/require-llvm-16.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-From 8d86cd22a743c39a04d34d4cf1a104952cf7fbac Mon Sep 17 00:00:00 2001
-From: xiaoming <xiangluoming2015@outlook.com>
-Subject: [PATCH] require llvm 16
-
-diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
-index 0d4839e7..da078878 100644
---- a/cmake/build_helpers.cmake
-+++ b/cmake/build_helpers.cmake
-@@ -525,7 +525,7 @@ macro(addBundledLibraries)
- add_subdirectory(${EXTERN_LIBS_FOLDER}/llvm-demangle EXCLUDE_FROM_ALL)
- set_target_properties(LLVMDemangle PROPERTIES POSITION_INDEPENDENT_CODE ON)
- else()
-- find_package(LLVM REQUIRED Demangle)
-+ find_package(LLVM 16 REQUIRED Demangle)
- endif()
-
- if (NOT USE_SYSTEM_YARA)
diff --git a/app-editors/imhex/imhex-1.31.0.ebuild b/app-editors/imhex/imhex-1.32.2.ebuild
index 3d29199d1..e9aabc231 100644
--- a/app-editors/imhex/imhex-1.31.0.ebuild
+++ b/app-editors/imhex/imhex-1.32.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,14 +20,11 @@ S_PATTERNS="${WORKDIR}/ImHex-Patterns-ImHex-v${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+system-llvm"
-
-PATCHES=(
- "${FILESDIR}/require-llvm-16.patch"
- "${FILESDIR}/remove-Werror.patch"
-)
+IUSE="+system-llvm test"
+RESTRICT="test" # the tests need the shared library to work
DEPEND="
+ app-arch/zstd[zlib]
app-forensics/yara
>=dev-cpp/nlohmann_json-3.10.2
dev-libs/capstone
@@ -47,7 +44,7 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- system-llvm? ( <sys-devel/llvm-17 )
+ system-llvm? ( sys-devel/llvm )
app-admin/chrpath
gnome-base/librsvg
sys-devel/lld
@@ -61,6 +58,10 @@ pkg_pretend() {
}
src_configure() {
+ if use test; then
+ sed -ie "s/tests EXCLUDE_FROM_ALL/tests ALL/" "${S}/CMakeLists.txt"
+ fi
+
local mycmakeargs=(
-D CMAKE_BUILD_TYPE="Release" \
-D CMAKE_C_COMPILER_LAUNCHER=ccache \