aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-04-05 23:25:37 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-04-05 23:26:37 +0200
commit52ee6ff68ca357b277cecaaee3fcad33c69d8b0e (patch)
tree8a6c11d35ff14fde616172b9f55d517cd1b9840b /app-shells
parentapp-shells/fzf-tab: initial import (diff)
downloadguru-52ee6ff68ca357b277cecaaee3fcad33c69d8b0e.tar.gz
guru-52ee6ff68ca357b277cecaaee3fcad33c69d8b0e.tar.bz2
guru-52ee6ff68ca357b277cecaaee3fcad33c69d8b0e.zip
app-shells/zsh-history-substring-search: initial import
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-history-substring-search/Manifest1
-rw-r--r--app-shells/zsh-history-substring-search/metadata.xml17
-rw-r--r--app-shells/zsh-history-substring-search/zsh-history-substring-search-1.0.2.ebuild33
3 files changed, 51 insertions, 0 deletions
diff --git a/app-shells/zsh-history-substring-search/Manifest b/app-shells/zsh-history-substring-search/Manifest
new file mode 100644
index 000000000..73017df55
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/Manifest
@@ -0,0 +1 @@
+DIST zsh-history-substring-search-1.0.2.tar.gz 9074 BLAKE2B 26c6a080f82586eef9b33bfbe1da89951a6bb9d8e7362dca83d90b9d491e3cd497fb3b4be2ab1a94082351711b941bd7942cd554e7e4d93a69d4168ef13f80ee SHA512 9547cdd74f6bd5b102ca29b7b455cd4ce7450fe86864b5a149365de4c37d3da887edb403b195e80c142fe61861a3e4c063a5d8ba08ec0532b27a1207c80a023d
diff --git a/app-shells/zsh-history-substring-search/metadata.xml b/app-shells/zsh-history-substring-search/metadata.xml
new file mode 100644
index 000000000..129a6e5e3
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zsh-users/zsh-history-substring-search</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ A clean-room implementation of the Fish shell's history search
+ feature, where you can type in any part of any command from
+ history and then press chosen keys, such as the UP and DOWN
+ arrows, to cycle through matches.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.0.2.ebuild b/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.0.2.ebuild
new file mode 100644
index 000000000..52a8faa38
--- /dev/null
+++ b/app-shells/zsh-history-substring-search/zsh-history-substring-search-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="ZSH port of Fish history search (up arrow)"
+HOMEPAGE="https://github.com/zsh-users/zsh-history-substring-search"
+SRC_URI="https://github.com/zsh-users/zsh-history-substring-search/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/async.zsh
+at the end of your ~/.zshrc"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins ${PN}.zsh
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}